Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 815944 - [abrt] evolution-3.2.3-2.fc16: __pthread_mutex_lock: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-3.2.3-2.fc16: __pthread_mutex_lock: Process /usr/bin/evoluti...
Keywords:
Status: CLOSED DUPLICATE of bug 699276
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5f29904eb16772d17509360db4f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-24 20:45 UTC by Christopher Beland
Modified: 2012-04-25 09:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-25 09:36:06 UTC


Attachments (Terms of Use)
File: maps (deleted)
2012-04-24 20:45 UTC, Christopher Beland
no flags Details
File: build_ids (deleted)
2012-04-24 20:45 UTC, Christopher Beland
no flags Details
File: dso_list (deleted)
2012-04-24 20:46 UTC, Christopher Beland
no flags Details
File: xsession_errors (deleted)
2012-04-24 20:46 UTC, Christopher Beland
no flags Details
File: backtrace (deleted)
2012-04-24 20:46 UTC, Christopher Beland
no flags Details
File: gconf_subtree (deleted)
2012-04-24 20:46 UTC, Christopher Beland
no flags Details

Description Christopher Beland 2012-04-24 20:45:54 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        evolution
comment:        Crashed after setting up a meeting. Earlier today switched from IMAP to IMAP+
crash_function: __pthread_mutex_lock
executable:     /usr/bin/evolution
kernel:         3.3.2-1.fc16.x86_64
pid:            8508
pwd:            /home/cbeland
reason:         Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
time:           Tue 24 Apr 2012 04:36:17 PM EDT
uid:            500
username:       cbeland

backtrace:      Text file, 57648 bytes
build_ids:      Text file, 9758 bytes
dso_list:       Text file, 24601 bytes
gconf_subtree:  Text file, 13256 bytes
maps:           Text file, 112381 bytes
xsession_errors: Text file, 4428 bytes

environ:
:XDG_VTNR=7
:XDG_SESSION_ID=11
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:TERM=dumb
:SHELL=/bin/tcsh
:XDG_SESSION_COOKIE=8c730b6b8da4781ea58e1fe200000011-1335279354.264817-1457005711
:GNOME_KEYRING_CONTROL=/tmp/keyring-4xTNhm
:IMSETTINGS_MODULE=none
:USER=cbeland
:USERNAME=cbeland
:DESKTOP_SESSION=gnome
:PATH=/usr/local/bin:/usr/bin:/bin:/home/cbeland/svn-working/mhdevtools
:QT_IM_MODULE=xim
:PWD=/home/cbeland
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=2766
:GDMSESSION=gnome
:SHLVL=1
:XDG_SEAT=seat0
:HOME=/home/cbeland
:LOGNAME=cbeland
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-GQ0BJtqt2W,guid=dd245b8b95148a40ace679b100000623
:WINDOWPATH=7
:DISPLAY=:0
:XDG_RUNTIME_DIR=/run/user/cbeland
:XAUTHORITY=/var/run/gdm/auth-for-cbeland-bRMXCH/database
:HOSTTYPE=x86_64-linux
:VENDOR=unknown
:OSTYPE=linux
:MACHTYPE=x86_64
:GROUP=cbeland
:HOST=localhost.localdomain
:MAIL=/var/spool/mail/cbeland
:HOSTNAME=localhost.localdomain
:LS_COLORS=
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:SVN_EDITOR=emacs
:WHOAMI=cbeland
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2928,unix/unix:/tmp/.ICE-unix/2928
:GPG_AGENT_INFO=/tmp/keyring-4xTNhm/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-4xTNhm/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:DESKTOP_STARTUP_ID=gnome-shell-2972-localhost.localdomain-evolution-17_TIME21973465
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=8508

smolt_data:
:
:
:General
:=================================
:UUID: d1b86bc3-855b-409c-bb38-e5a280f9cd0a
:OS: Fedora release 16 (Verne)
:Default run level: 5
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4788.97
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 520  @ 2.40GHz
:CPU Stepping: 2
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2400
:System Memory: 3755
:System Swap: 1998
:Vendor: Hewlett-Packard
:System: HP EliteBook 8440p 
:Form factor: Notebook
:Kernel: 3.3.2-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11362:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:32902:32902) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:4156:5930) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:32902:32902) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:32902:32902) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:32902:32902) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15151:4156:5930) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:4156:5930) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:4156:5930) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:16953:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6200 2x2 AGN
:(32902:4330:4156:5930) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:4156:5930) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:4156:5930) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:4156:5930) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:4156:5930) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:70:4156:5930) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:4156:5930) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:4156:5930) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:4156:5930) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15190:4156:5930) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(32902:15207:4156:5930) pci, serial, 16550_SERIAL, 5 Series/3400 Series Chipset KT Controller
:(4480:2098:4156:5930) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4156:5930) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1142:4156:5930) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 60479165 34336495 33731303 15138816 14527606 14527606
:

var_log_messages:
:Apr 24 11:37:43 localhost yum[4021]: Installed: evolution-mapi-3.2.3-1.fc16.x86_64
:Apr 24 16:35:48 localhost kernel: [21931.787771] evolution[8484]: segfault at a ip 0000003b4e85ff78 sp 00007fde22df39a0 error 4 in libglib-2.0.so.0.3000.2[3b4e800000+11e000]
:Apr 24 16:35:51 localhost abrt[8497]: Saved core dump of pid 6374 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-04-24-16:35:48-6374 (272076800 bytes)
:Apr 24 16:36:17 localhost kernel: [21960.758874] evolution[8521]: segfault at 10 ip 0000003b4d009db4 sp 00007f646fffea80 error 4 in libpthread-2.14.90.so[3b4d000000+17000]
:Apr 24 16:36:18 localhost abrt[8552]: Saved core dump of pid 8508 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-04-24-16:36:17-8508 (112328704 bytes)

Comment 1 Christopher Beland 2012-04-24 20:45:57 UTC
Created attachment 579992 [details]
File: maps

Comment 2 Christopher Beland 2012-04-24 20:45:59 UTC
Created attachment 579993 [details]
File: build_ids

Comment 3 Christopher Beland 2012-04-24 20:46:00 UTC
Created attachment 579994 [details]
File: dso_list

Comment 4 Christopher Beland 2012-04-24 20:46:02 UTC
Created attachment 579996 [details]
File: xsession_errors

Comment 5 Christopher Beland 2012-04-24 20:46:03 UTC
Created attachment 579997 [details]
File: backtrace

Comment 6 Christopher Beland 2012-04-24 20:46:05 UTC
Created attachment 579999 [details]
File: gconf_subtree

Comment 7 Milan Crha 2012-04-25 09:36:06 UTC
Thanks for a bug report. The crash actually happens in IMAP+ code, and I found a similar bug report filled already, thus I'm marking this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 699276 ***


Note You need to log in before you can comment on or make changes to this bug.