Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81594 - Computer constantly beeps after installing ethereal-gnome-0.9.8-0.73.0.i386.rpm
Summary: Computer constantly beeps after installing ethereal-gnome-0.9.8-0.73.0.i386.rpm
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ethereal
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 22:51 UTC by Craig McCluskey
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-17 08:57:44 UTC


Attachments (Terms of Use)

Description Craig McCluskey 2003-01-10 22:51:02 UTC
After installing ethereal-0.9.8-0.73.0.i386.rpm and
ethereal-gnome-0.9.8-0.73.0.i386.rpm, any user who logs on gets a repetitive
beep from the computer.


This beeping, which goes on forever every couple of seconds (and was driving me
absolutely BATTY!), is because the following line is added at each beep to
~/.xsession-errors:

File error: Permission denied, /usr/share/gnome/apps/Applications/Network


This occurs when ethereal-gnome-0.9.8-0.73.0.i386.rpm is installed because
the following file is installed:

-rw-r--r--    1 root    root              215 Dec 19 04:53
/usr/share/gnome/apps/Applications/Network/ethereal.desktop

Since the directory /usr/share/gnome/apps/Applications/Network does not exist
before rpm installs the file ethereal.desktop, rpm creates the directory with
root's present umask. If that umask is 027 (as mine is!), the Network directory
is created as:

drwxr-x---    2 root         4096 Jan 10 10:52 Network

which is not readable by anyone but root.

This can be solved by adding creation of the directory to the RPM file:


drwxr-xr-x    2 root    root     0 Dec 19 09:05
/usr/share/gnome/apps/Applications/Network

Comment 1 Trevor Cordes 2003-01-17 08:44:55 UTC
Confirmed: I had the same problem and Craig's solution solved it.  Thanks!


Comment 2 Phil Knirsch 2003-01-17 08:57:44 UTC
OK, noted. I will check in newer ethereal versions if that problem still exists.
We probably won't rerelease the ethereal errata because of this though, as the
standard umask for root typically is 022, which will create world readable
directories.

Thanks for reporting it though.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.