Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81587 - spurious 8259A interrupt system hangs
Summary: spurious 8259A interrupt system hangs
Keywords:
Status: CLOSED DUPLICATE of bug 72387
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 20:21 UTC by dsingh
Modified: 2006-02-21 18:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:05 UTC


Attachments (Terms of Use)

Description dsingh 2003-01-10 20:21:11 UTC
Description of problem:When I try to load Linux on a new Compaq Presario 905US 
laptop I get, very early in the installation phase of loading Redhat's Linux 
8.0,  a "Spurious 8259a interrupt: IRQ 7" message, and the system hangs. I've 
tried to boot using Linux pci=off, which eliminates the message and the 
installation appears to work, but after the system tries to boot I get a 
kernel panic.


Version-Release number of selected component (if applicable):
Kernel 2-4-18-14

How reproducible: Everytime


Steps to Reproduce:
1. Try intall of Redhat 8.0 on Compaq Presario 905Us or 906US laptop (see 
additonal info)
2. 
3.
    
Actual results: Install hanges. (If pci=off is not set) If set no support for 
pci devices e.g. ethernet, sound devices


Expected results: Expect to install RH 8.0 without problems


Additional info:I've been trying and trying and trying to get RH8 installed on 
my new 
> Compaq Presario 906US laptop with the following:
> 
> 256MB RAM
> ATI Radeon Mobility 320M Graphics (which isn't supported by XFree86 yet)
> Realtek RTL8139 Family PCI Fast Ethernet
> SoundMAX (I'm not exactly sure of the specs)
> Toshiba CD-RW/DVD
> 
> I *finally* can install and boot RH8 by doing the following:
> 1. Before I begin the install, I have to enter "linux pci=off"
>      Otherwise, I get the "spurious 8259A" error.
> 2. After the install, I reboot. When I get the GRUB screen to select 
> which OS to boot (I'm dual booting WinXP-- I press "a" which let's me edit 
the kernel 
> arguements.
> 3. At the end of the kernel arguements I enter "noisapnp nousb pci=off"
> 4. Press Enter. Everything boots correctly and I login to RH8.
> 
> Sounds fine except I can't use my Ethernet card, sound, etc. because I 
> had to disable pci.
> 
> My question: How can I activate my pci cards after booting? If I don't 
> use "noisapnp nousb pci=off" I get a Kernel Panic.

Comment 1 Arjan van de Ven 2003-01-30 19:42:58 UTC

*** This bug has been marked as a duplicate of 72387 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.