Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 815832 - Seam faces fails to deploy without Pretty faces on EAP6
Summary: Seam faces fails to deploy without Pretty faces on EAP6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: jbossas
Version: 6.0
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Marek Novotny
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-24 15:49 UTC by Adam Kovari
Modified: 2015-09-01 03:03 UTC (History)
1 user (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-25 08:11:48 UTC
Type: Bug


Attachments (Terms of Use)
demo app with pom.xml included (deleted)
2012-04-24 15:49 UTC, Adam Kovari
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker AS7-290 Major Resolved CNFEs for Seam 3 optional dependencies 2018-10-01 10:25:23 UTC
Red Hat One Jira Issue Tracker SEAMFACES-187 Major Resolved Seam faces fails to deploy without Pretty faces on AS7 2018-10-01 10:25:23 UTC

Description Adam Kovari 2012-04-24 15:49:03 UTC
Created attachment 579898 [details]
demo app with pom.xml included

Description of problem:
Deploying application with following dependency:
		<dependency>
			<groupId>org.jboss.seam.faces</groupId>
			<artifactId>seam-faces</artifactId>
			<version>3.1.0.Final</version>
			<scope>runtime</scope>
		</dependency>

Causes following output:
17:40:00,409 INFO  [org.jboss.weld.ClassLoading] (MSC service thread 1-3) catching: org.jboss.weld.resources.spi.ResourceLoadingException: java.lang.ClassNotFoundException: org.jboss.seam.faces.rewrite.RewriteConfiguration from [Module "deployment.exam.war:main" from Service Module Loader]
	at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:74) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.weld.bootstrap.BeanDeployer.loadClass(BeanDeployer.java:98) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployer.addClass(BeanDeployer.java:77) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployer.addClasses(BeanDeployer.java:123) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.BeanDeployment.createBeans(BeanDeployment.java:184) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.weld.bootstrap.WeldBootstrap.deployBeans(WeldBootstrap.java:349) [weld-core-1.1.6.Final-redhat-0-todo.jar:2012-03-21 18:52]
	at org.jboss.as.weld.WeldContainer.start(WeldContainer.java:82) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.as.weld.services.WeldService.start(WeldService.java:76) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_31]
Caused by: java.lang.ClassNotFoundException: org.jboss.seam.faces.rewrite.RewriteConfiguration from [Module "deployment.exam.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:68) [jboss-as-weld-7.1.1.Final-redhat-1.jar:7.1.1.Final-redhat-1]
	... 12 more


Workaround is to add prettyfaces dependency:
		<dependency>
			<groupId>com.ocpsoft</groupId>
			<artifactId>prettyfaces-jsf2</artifactId>
			<version>3.3.2</version>
		</dependency>

Then deployment works fine.

Version-Release number of selected component (if applicable):
JBoss EAP 6.0 beta and ER5

How reproducible:
Always

Steps to Reproduce:
1. Deploy attached demo
2.
3.
  
Actual results:
unsuccessful deployment

Expected results:
successful deployment

Additional info:
please request

Comment 1 Marek Novotny 2012-04-25 08:08:25 UTC
Seam 3 is not in any way tested, supported on EAP6 JBoss AS. This issue will be rejected


Note You need to log in before you can comment on or make changes to this bug.