Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81564 - error from initscript when using hostnames for servers
Summary: error from initscript when using hostnames for servers
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 15:46 UTC by Tim Waugh
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-30 16:10:30 UTC


Attachments (Terms of Use)

Description Tim Waugh 2003-01-10 15:46:53 UTC
Description of problem:
The initscript gives errors:

ntpd: Removing firewall opening for ntp.demon.co.uk port 123iptables: Bad rule
(does a matching rule exist in that chain?)
[etc]

Version-Release number of selected component (if applicable):
ntp-4.1.1b-1

How reproducible:
100%

Steps to Reproduce:
1. Use 'server hostname.domain.whatever' in ntp.conf
2. service ntp restart
    
Actual results:
Errors.

Expected results:
No errors.

Additional info:
It could either ignore non-IP entries, or (better) use dig to figure out the IP
addresses for each hostname; in the latter case it needs to start up after named
of course.

Comment 1 Harald Hoyer 2003-01-30 16:10:30 UTC
1. hostnames are not safe and the name server could be down... not reliable.
2. maybe ntpd is not running anymore or your firewall was modified in the meantime
I could direct error messages to /dev/null, but this is not intended..



Note You need to log in before you can comment on or make changes to this bug.