Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81562 - dvips -R0 Failure to execute command
Summary: dvips -R0 Failure to execute command
Keywords:
Status: CLOSED DUPLICATE of bug 71650
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 15:21 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:05 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-10 15:21:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
dvips fails to execute an embedded command even with option -R0

example:

[jarioksa@pc112145 biogeo]$ dvips -R0 -q -o hm.ps prosptest2.dvi
dvips: Failure to execute /usr/local/bin/bmeps -p2 -er8 figs/florareg.png;
continuing

I found a discussion about this in the Debian lists, where it was identified as
a bug (Debian bug #156406). The suggested cure didn't work in my case, when I
tried with the following patch (or then I mucked up with using rpmbuild and
editing the spec file so that this was not applied):

--- teTeX-1.0/texk/dvipsk/output.c.orig 2003-01-10 12:55:43.000000000 +0200
+++ teTeX-1.0/texk/dvipsk/output.c      2003-01-10 12:56:29.000000000 +0200
@@ -174,7 +174,7 @@
       if (_osmode == OS2_MODE) {
 #endif
       if (secure == 0)
-         f = popen(s, FOPEN_RBIN_MODE) ;
+         f = popen(s, "r") ;
 #ifdef OS2
       }
 #endif

cheers, Jari Oksanen
Oulu, Finland

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put in LaTeX file an instruction to execute a command, such as:
\DeclareGraphicsRule{.png}{eps}{.bb}{`cat #1}

2. Run latex
3. dvips -R0 the output dvi
    

Actual Results:  Get a message like above:
dvips: Failure to execute...

Expected Results:  dvips to execute the command (like documented for -R0 switch)

Additional info:

Comment 1 Tim Waugh 2003-01-10 15:25:42 UTC

*** This bug has been marked as a duplicate of 71650 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.