Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81558 - ide-scsi setup incorrectly
Summary: ide-scsi setup incorrectly
Keywords:
Status: CLOSED DUPLICATE of bug 101209
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-01-10 14:27 UTC by Gerald Teschl
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:05 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-01-10 14:28:02 UTC
kernel-2.4.20-2.2

I have a laptop with an ide dvd/cdrw drive. It was set up properly
(hdc=ide-scsi) but if I try to mount the cdrom I get:

[root@soliton root]# mount /mnt/cdrom
udf: registering filesystem
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O error, dev 16:00 (hdc), sector 64
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O error, dev 16:00 (hdc), sector 1248
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O error, dev 16:00 (hdc), sector 1024
UDF-fs: No partition found (1)
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O error, dev 16:00 (hdc), sector 64
isofs_read_super: bread failed, dev=16:00, iso_blknum=16, block=32
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)

and it fails. This works fine under RedHat 8.0.

Comment 1 Alan Cox 2003-01-10 15:20:12 UTC
can you attach the fstab line for /mnt/cdrom,  the boot up messages and a dmesg
after the failure case

Thanks
Alan


Comment 2 Gerald Teschl 2003-01-11 11:01:29 UTC
Sorry, barking up the wrong tree. fstab had two entries: cdrom, cdrom1
with cdrom pointing to /dev/hdc and cdrom1 pointing to /dev/scd0

This was an upgrade from 8.0 to phoebe.

This box has only two ide drives

/dev/hda harddrive
/dev/hdc dvd/cdrw combo

Reassigining to anaconda.

Comment 3 Jeremy Katz 2003-01-12 19:45:23 UTC
anaconda doesn't set up the fstab, kudzu does

Comment 4 Bill Nottingham 2003-01-13 20:17:22 UTC
Can you attach the *full* fstab?

Comment 5 Gerald Teschl 2003-01-16 15:10:30 UTC
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/hda5               /mnt/store              ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda2               swap                    swap    defaults        0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0

Comment 6 Gerald Teschl 2003-01-24 16:05:25 UTC
I fixed fstab and the cdrom link and upgraded to phoebe2.

Now I have two identical lines

/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0

and /dev/cdrom points to /dev/hdc again.

Comment 7 Bill Nottingham 2003-01-30 05:49:19 UTC
Did you ever boot without 'hdc=ide-scsi'?

Comment 8 Gerald Teschl 2003-01-30 14:45:24 UTC
No, but I sometimes use a custom kernel with acpi support. However,
it seems stable now and the link does not change anymore.

Comment 9 Bill Nottingham 2003-01-30 17:19:03 UTC
OK, please reopen if it comes back.

Comment 10 Gerald Teschl 2003-04-24 11:44:30 UTC
It is here again;-(

I have removed the "kudzu" option from fstab and hence did not notice
this anymore. But I just looked into fstab and this is how it looks
like:

/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660
noauto,owner,kudzu,ro 0 0

If I remove the "cdrom1" entries they will reappear (one per boot) even if
kudzu is turned off!?

Comment 11 Gerald Teschl 2003-07-31 10:20:54 UTC
I still have this problem on both my laptop (severn) and a box at home
(shirke plus all updates). It does no longer seem to create multiple entries.
I don't know what triggers updfstab to be run, but I noted that if I
remove ide-scsi it will rmove the cdrom1 entry and after modprob ide-scsi
it will show up again.

It definitely should handle this situation smarter;-)



Comment 12 Bill Nottingham 2003-08-01 20:17:16 UTC
Collapsing into one entry.

*** This bug has been marked as a duplicate of 101209 ***

Comment 13 Red Hat Bugzilla 2006-02-21 18:51:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.