Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81553 - German umlauts and bash on console or via ssh
Summary: German umlauts and bash on console or via ssh
Keywords:
Status: CLOSED DUPLICATE of bug 74925
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 13:09 UTC by Björn Gerhart
Modified: 2012-04-24 18:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:04 UTC


Attachments (Terms of Use)

Description Björn Gerhart 2003-01-10 13:09:57 UTC
Description of problem:
When I type in some chars and delete them
with backspace everything is fine. The same done with german
umlauts (e.g. üöä) causes that backspace can delete chars behind
the leftmost: the promt can be deleted also. So for every umlaut
TWO chars can be deleted.

Version-Release number of selected component (if applicable):


How reproducible:
* German-latin1 keyboard is loaded
* bash is the login shell
* error happens on text console or ssh connection

Steps to Reproduce:
1) go to a text console (_no_ console within X!)
2) enter "loadkeys de-latin1-nodeadkeys"
3) type _one_ German umlaut (ä, ö, ü or Ã)
4) press <backspace> two times
    
Actual results:
The cursor enters a position which is not allowed. Its position is within the
prompt.

Expected results:
After the second press of <backspace> the cursor must not go further to the left.

Additional info:
* When entering an umlaut-key on the user login, the character is not shown
correctly; two special characters are shown instead of one umlaut

Comment 1 Miloslav Trmac 2003-01-10 14:17:17 UTC
Duplicate of bug 74925, fixed in rawhide.

Comment 2 Tim Waugh 2003-01-10 19:19:30 UTC

*** This bug has been marked as a duplicate of 74925 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.