Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81548 - Segfault when cancelling RHN configuration
Summary: Segfault when cancelling RHN configuration
Keywords:
Status: CLOSED DUPLICATE of bug 80511
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-10 12:40 UTC by Telsa Gwynne
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:04 UTC


Attachments (Terms of Use)

Description Telsa Gwynne 2003-01-10 12:40:19 UTC
Description of problem: Segfault when cancelling RHN configuration. 

Version-Release number of selected component (if applicable): beta3.

How reproducible: Both times tried.

Steps to Reproduce:
1. Go through firstboot to RHN set up.
2. "Yes, I want to subscribe".
3: alt-N to 'Next'
3. When configuration dialogue box comes up, hit Cancel.
    
Actual results:

Left with blank X scree with mouse pointer. On control-alt-backspace back to text, 
get many error messages. Not sure where the to start, so including everything on 
the screen.  The precise line numbers changed the second time, but the error
messages
are the same.

(firstboot.py:3848): GLib-GObject-WARNING **: invalid uninstantiatable type 
'<unknown>' in cast to 'GtkOjbject'

(firstboot.py:3848): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type '<unkown>'

(firstboot.py:3848): GLib-GObject-CRITICAL: file gsignal.c: line 2056
 (g_signal_handlers_destroy): assertion 'G_TYPE_CHECK_INSTANCE 
(instance)' failed.
/usr/sbin/firstbook: like 4:   3848 Segmentation fault 
/usr/bin/python2.2 /usr/share/firstbook/firstbook.phy $*

Expected results: On hitting cancel on the configuration for RHN, 
should return to the RHN "Yes, I want to subscribe"/"No, I do not"
choice. 

Additional info:

 1: The line numbers the second time: (firstboot.py: 3941) for all bits
     at the starts of lines; and 2056 remained the same.

 2: What on earth is uninstantiatable? :) 

Marked as high because it's pretty easy to do this, and it's a nasty result.

Comment 1 Brent Fox 2003-01-10 14:33:52 UTC
I think this is a dupe of bug #80511.  Basically, any time a GtkInvisible widget
was used, it would make Python segfault, which would take firstboot down with
it.  Jeremy fixed this in pygtk2-1.99.14-1.  

Closing as a dupe of bug 80511.  Please reopen if upgrading pygtk doesn't make
this go away.

*** This bug has been marked as a duplicate of 80511 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:04 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.