Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81542 - gnome-terminal wouldn't display Korean input properly
Summary: gnome-terminal wouldn't display Korean input properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-10 06:11 UTC by David Joo
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-07 04:06:51 UTC


Attachments (Terms of Use)
Wrong output in gnome term (deleted)
2003-01-10 06:13 UTC, David Joo
no flags Details
Hanterm's right output (deleted)
2003-01-10 06:14 UTC, David Joo
no flags Details

Description David Joo 2003-01-10 06:11:40 UTC
Description of problem:
Gnome-terminal doesn't display korean inputs properly

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. fresh install
2. start gnome-terminal
3. try to type korean with key-sequence of "rkskekfk" then it will show with
strange mixture of characters.

    
Actual results:
write up the right characters

Expected results:
mixed up or broken up characters

Additional info:

Comment 1 David Joo 2003-01-10 06:13:44 UTC
Created attachment 89282 [details]
Wrong output in gnome term

Comment 2 David Joo 2003-01-10 06:14:20 UTC
Created attachment 89283 [details]
Hanterm's right output

Comment 3 David Joo 2003-02-03 23:40:23 UTC
I have forced installation of old ami, in that way, to see whether ami's upgrade
brought this, however, with the old ami, the result is exactly the same

Comment 4 Matt Wilson 2003-02-20 02:24:31 UTC
I can not reproduce this.  Entering random hangul and it looks the same on both.
 Do you have some better instructions on how to reproduce?  I also copied and
pasted text from mozilla at www.yahoo.co.kr into both hterm and gnome-terminal
and it looks the same.


Comment 5 Matt Wilson 2003-02-20 05:09:40 UTC
Keypress, modifiers=0x0, keyval=0x72, raw string=`r'.
Keypress taken by IM.
Input method pre-edit changed (ã±,1).
Keypress, modifiers=0x0, keyval=0x6b, raw string=`k'.
Keypress taken by IM.
Input method pre-edit changed (ê°,1).
Keypress, modifiers=0x0, keyval=0x73, raw string=`s'.
Keypress taken by IM.
Input method pre-edit changed (ê°,1).
Keypress, modifiers=0x0, keyval=0x6b, raw string=`k'.
Keypress taken by IM.
Input method pre-edit changed (ê°,1).
Keypress, modifiers=0x0, keyval=0x0, raw string=`'.
Input method committed `ê°'.
Input method pre-edit changed (,0).
Input method pre-edit changed (ë,1).
Input method committed `ë'.
Input method pre-edit changed (,1).
Keypress taken by IM.


Comment 6 Matt Wilson 2003-02-20 05:13:35 UTC
Do Ami Preference -> Input Options -> Commit by characters

bring up gnome-terminal
press shift+space
type rksk
it should say ê°ë, but instead it says ëê°

Comment 7 Nalin Dahyabhai 2003-02-20 08:23:51 UTC
Looks like the input method was being reset prematurely in some cases.  Please
check if 0.10.22 fixes it.

Comment 8 David Joo 2003-02-20 23:43:35 UTC
Nalin Thanks for the updates, however, it only solved half of the problem.
The input that I have posted up there now works. However, if I add another
combination, it won't work.
the input combination this time is..
"ehdgoanfrhk" <- here "ehd" is one char, "go" is one, "anf" is another one,
"rhk" is one.

For Korean it could be many as 4-5 combination can make up a one character.
For the update that has been posted 2 combination works but after 2, it breaks.
BTW, the combination that I wrote up this time is "The water of the East Sea
and" should look like "ëí´ë¬¼ê³¼"

Thanks is advance.

Comment 9 Nalin Dahyabhai 2003-02-21 01:30:32 UTC
Okay, I can't be sure just when I'm supposed to reset the IM, so for now I'm
just not going to reset it.  This appears to fix the other case.  Please check
0.10.22-2 and let me know if there are any problems in its behavior.


Note You need to log in before you can comment on or make changes to this bug.