Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81502 - working script fails under debugger with perl-5.8.0-82
Summary: working script fails under debugger with perl-5.8.0-82
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-09 22:55 UTC by Jonathan Kamens
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 07:28:02 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2003-01-09 22:55:43 UTC
I have a script which fails as follows when run under the debugger (i.e., just
start the script with "perl -d <script> <args>" and type "c RET") but not when
run without the debugger:

print() on unopened filehandle old_watch at
/home/jik/dev/bulkmail/bounces/filter.pl line 136, <> chunk 1.
        DB::DB called at /home/jik/dev/bulkmail/bounces/filter.pl line 111
Can't coerce GLOB to string in concat at
/home/jik/dev/bulkmail/bounces/filter.pl line 136, <> chunk 1.
        DB::DB called at /home/jik/dev/bulkmail/bounces/filter.pl line 111
Debugged program terminated.  Use q to quit or R to restart,

The code around line 136 looks like this:

   132	
   133		    $count++;
   134	
   135		    if (! &filter($_)) {
   136		      print_it:
   137			print(FILTEROUT $orig) || die "write to $filter_output: $!";
   138		    }
   139		}
   140	    }

Note that the failure happens right after a call to "goto print_it" from
elsewhere in the script.

Unfortunately, I can't find a simple test case for the problem, and I can't send
you the whole script because it's proprietary.

Comment 1 Warren Togami 2005-05-28 07:28:02 UTC
We cannot possibly solve problems that we cannot reproduce due to lack of source
code or simple test case.  Sorry.


Note You need to log in before you can comment on or make changes to this bug.