Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 814971 - USB printer detected but installation fails
Summary: USB printer detected but installation fails
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-printer-applet
Version: 17
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-21 18:56 UTC by Jon Burgess
Modified: 2013-08-01 11:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-01 11:41:08 UTC


Attachments (Terms of Use)
output from lpinfo (deleted)
2012-04-23 18:52 UTC, Jon Burgess
no flags Details

Description Jon Burgess 2012-04-21 18:56:42 UTC
Description of problem:

I plugged in a USB printer to a clean install of F17 beta. A message popped up from the printer applet saying 'Configuring new printer'. After a little while I tried printing something in Firefox and no printers were listed, similarly no printers are shown in the printer configuration 

Version-Release number of selected component (if applicable):

Fedora-17-Beta-i686-Live-KDE.iso, installed to HD & yum update
cups-1.5.2-12.fc17.i686
system-config-printer-kde-4.8.2-1.fc17.i686


How reproducible:

Have not tried

Steps to Reproduce:
1. Plugged in HP CP2025DN printer via USB
2. Tried to print in Firefox
3. Opened printed config in system settings
  
Actual results:
Message saying printer was being installed but does not show up afterwards

Expected results:
Printer available in firefox etc

Additional info:

Apr 21 19:18:26 eee kernel: [  267.747126] usb 1-2: new high-speed USB device number 4 using ehci_hcd
Apr 21 19:18:26 eee kernel: [  267.862067] usb 1-2: New USB device found, idVendor=03f0, idProduct=5417
Apr 21 19:18:26 eee kernel: [  267.862085] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 21 19:18:26 eee kernel: [  267.862099] usb 1-2: Product: HP Color LaserJet CP2025dn
Apr 21 19:18:26 eee kernel: [  267.862110] usb 1-2: Manufacturer: Hewlett-Packard
Apr 21 19:18:26 eee kernel: [  267.862120] usb 1-2: SerialNumber: 00CNFSC0xxxx
Apr 21 19:18:26 eee mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-2"
Apr 21 19:18:26 eee mtp-probe: bus: 1, device: 4 was not an MTP device
Apr 21 19:18:26 eee kernel: [  267.914561] usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x03F0 pid 0x5417
Apr 21 19:18:26 eee kernel: [  267.914640] usbcore: registered new interface driver usblp

I noticed this traceback in the .xsession-errors:

Caught non-fatal exception.  Traceback:
File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 733, in setDataButtonState
    printable = (self.ppd != None and
AttributeError: 'GUI' object has no attribute 'ppd'
Continuing anyway..
Traceback (most recent call last):
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 436, in on_tvMainList_cursor_changed
    self.fillServerTab()
  File "/usr/share/kde4/apps/system-config-printer-kde/system-config-printer-kde.py", line 1785, in fillServerTab
    self.server_settings = self.cups.adminGetServerSettings()
  File "/usr/share/kde4/apps/system-config-printer-kde/authconn.py", line 218, in <lambda>
    return lambda *args, **kwds: self._authloop (fname, fn, *args, **kwds)
  File "/usr/share/kde4/apps/system-config-printer-kde/authconn.py", line 226, in _authloop
    if self._perform_authentication () == 0:
  File "/usr/share/kde4/apps/system-config-printer-kde/authconn.py", line 405, in _perform_authentication
    self._perform_authentication_with_dialog ()
  File "/usr/share/kde4/apps/system-config-printer-kde/authconn.py", line 462, in _perform_authentication_with_dialog
    d = AuthDialog (parent=self._parent)
NameError: global name 'AuthDialog' is not defined

Comment 1 Jon Burgess 2012-04-21 19:20:21 UTC
Originally I didn't have hplip installed. Once I installed this and plugged the printer in again then it worked OK (with the popup message '... is ready for printing').

Comment 2 Jiri Popelka 2012-04-23 10:29:58 UTC
Please attach an output from the following command when the printer is on:
su -c "lpinfo -l -v"

Comment 3 Jon Burgess 2012-04-23 18:52:30 UTC
Created attachment 579659 [details]
output from lpinfo

Comment 4 Fedora End Of Life 2013-07-04 03:43:40 UTC
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2013-08-01 11:41:14 UTC
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.