Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 814875 - velocity (Fedora 17) depends on both tomcat6-servlet-2.5-api and tomcat-servlet-3.0-api
Summary: velocity (Fedora 17) depends on both tomcat6-servlet-2.5-api and tomcat-servl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: velocity
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 819555 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-20 22:31 UTC by Mattias Ellert
Modified: 2012-06-15 12:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-15 12:26:54 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2012-04-20 22:31:59 UTC
Description of problem:
Installing velocity ob F17 drags in both tomcat6-servlet-2.5-api and tomcat-servlet-3.0-api as dependencies

Version-Release number of selected component (if applicable):
velocity-1.7-3.fc17

Steps to Reproduce:
1. yum install velocity on Fedora 17
  
Actual results:
Both the tomcat6 and the tomcat7 version of the servlet api are installed when dependencies are resolved

Expected results:
Only one version of the servlet dependency installed.

Additional info:
The velocity rpm itself has dependencies on tomcat6-servlet-2.5-api and hsqldb.
The hsqldb rpm has a dependency on tomcat-servlet-3.0-api

Comment 1 Stanislav Ochotnicky 2012-06-05 13:00:25 UTC
*** Bug 819555 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2012-06-05 13:17:23 UTC
velocity-1.7-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/velocity-1.7-4.fc17

Comment 3 Fedora Update System 2012-06-07 02:30:21 UTC
Package velocity-1.7-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing velocity-1.7-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8892/velocity-1.7-4.fc17
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-06-15 12:26:54 UTC
velocity-1.7-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.