Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81483 - gcc won't compile system headers without warnings
Summary: gcc won't compile system headers without warnings
Keywords:
Status: CLOSED DUPLICATE of bug 81482
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-09 20:42 UTC by Pat Gunn
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:03 UTC


Attachments (Terms of Use)

Description Pat Gunn 2003-01-09 20:42:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
When I use the following gcc flags:
gcc -g -pedantic-errors  -Wall -O -pedantic -Wunused-parameter -Wunused-variable
-Wuninitialized -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wconversion
-Wsign-compare -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wmissing-format-attribute -Wpadded -Wredundant-decls -Wunreachable-code
-Winline -Wdisabled-optimization

On code that includes math.h on redhat8,
it gives the following error:

In file included from /usr/include/math.h:362,
                 from standard.h:107,
                 from ambs.h:27,
                 from amma.h:15,
                 from amvpv.h:14,
                 from amvpv.c:1:
/usr/include/bits/mathinline.h: In function `fabsf':
/usr/include/bits/mathinline.h:446: passing arg 1 of `__builtin_fabsf' as
`float' rather than `double' due to prototype
make[1]: *** [Linux_x86_glibc-2.2.93_gcc.debug/amvpv.o] Error 1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above

Additional info:

Comment 1 Pat Gunn 2003-01-10 14:19:41 UTC

*** This bug has been marked as a duplicate of 81482 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.