Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 814588 - lpgjavaruntime is bundled in eclipse-cdt-sdk
Summary: lpgjavaruntime is bundled in eclipse-cdt-sdk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-20 07:23 UTC by Alexander Kurtakov
Modified: 2012-04-25 05:08 UTC (History)
3 users (show)

Fixed In Version: eclipse-cdt-8.1.0-0.5.junom6.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-25 05:08:07 UTC


Attachments (Terms of Use)

Description Alexander Kurtakov 2012-04-20 07:23:05 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Alexander Kurtakov 2012-04-20 07:27:13 UTC
Sorry, real comment now:
/usr/lib64/eclipse/dropins/cdt-sdk/eclipse/plugins/net.sourceforge.lpg.lpgjavaruntime_1.1.0.v200803061910.jar in eclipse-cdt-sdk
is a real jar which should be replaced with a symlink. Also there is a generated requires osgi(net.sourceforge.lpg.lpgjavaruntime) in eclipse-cdt-parsers so the symlink seems to be needed there instead of in eclipse-cdt-sdk.

Comment 2 Jeff Johnston 2012-04-20 20:12:55 UTC
Yes, it should be removed.  Will do so.

Comment 3 Fedora Update System 2012-04-20 22:07:32 UTC
eclipse-cdt-8.1.0-0.5.junom6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-cdt-8.1.0-0.5.junom6.fc17

Comment 4 Fedora Update System 2012-04-21 21:06:41 UTC
Package eclipse-cdt-8.1.0-0.5.junom6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-cdt-8.1.0-0.5.junom6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6340/eclipse-cdt-8.1.0-0.5.junom6.fc17
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-04-25 05:08:07 UTC
eclipse-cdt-8.1.0-0.5.junom6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.