Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81437 - jobs command output cannot be processed further
Summary: jobs command output cannot be processed further
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-09 14:57 UTC by Rene Uittenbogaard
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-07 20:39:53 UTC


Attachments (Terms of Use)

Description Rene Uittenbogaard 2003-01-09 14:57:40 UTC
Description of problem:

The jobs command output cannot be sent through a pipe.

$ sleep 300 &
[1] 21238
$ jobs
[1]  + running    sleep 300
$ jobs | wc 
      0       0       0


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
$ sleep 300 &
[1] 21238
$ jobs
[1]  + running    sleep 300
$ jobs | wc 
      0       0       0


Actual Results:  'jobs' seems to produce no output when reading from the pipe.

Expected Results:  the pipe reading process should receive the same output as 
is printed on the terminal when just typing 'jobs'

Additional info:

Comment 1 Rene Uittenbogaard 2003-01-09 15:00:32 UTC
produced using zsh-4.0.4-8, but the bug is present in some earlier versions, 
too.

Comment 2 Jens Petersen 2003-02-10 14:01:16 UTC
Still seems to be present in zsh-4.0.6.

Comment 3 Jens Petersen 2003-05-01 01:10:08 UTC
Seems to be ok with zsh-4.0.6.

Comment 4 Rene Uittenbogaard 2003-05-07 09:46:13 UTC
Still doesn't work, even with 4.0.6:

/home/rene: sleep 1000&
[1] 1221
/home/rene: jobs
[1]  + running    sleep 1000
/home/rene: jobs | wc
0       0       0
/home/rene: echo $ZSH_VERSION
4.0.6
/home/rene: rpm -q zsh 
zsh-4.0.6-5




Comment 5 Rene Uittenbogaard 2003-05-07 09:51:58 UTC
Same for 4.0.6-7:

/home/rene: jobs 
[1]  + running    sleep 1000
/home/rene: jobs | wc 
      0       0       0
/home/rene: echo $ZSH_VERSION
4.0.6
/home/rene: rpm -q zsh
zsh-4.0.6-7
      

Comment 6 Jens Petersen 2003-05-07 20:39:53 UTC
Reproduced again :)  Not sure, why I thought it was ok.

Ok, it turns out this is a known problem - see the thread starting with

http://www.zsh.org/mla/users/2002/msg00755.html

and in particular http://www.zsh.org/mla/users/2002/msg00772.html

It seems 4.1 has some workaround for this.


Note You need to log in before you can comment on or make changes to this bug.