Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 814117 - json should not be used as dependency when install rhc client on Windows
Summary: json should not be used as dependency when install rhc client on Windows
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Command Line Interface
Version: 1.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Fotios Lindiakos
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-19 09:32 UTC by Meng Bo
Modified: 2014-01-13 01:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-28 03:21:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Meng Bo 2012-04-19 09:32:38 UTC
Description of problem:
According to US2145, json_pure should be used as dependency when installing rhc client on Windows and Mac.

Version-Release number of selected component (if applicable):
rhc-0.90.7
rhc-rest-0.0.14

How reproducible:
always

Steps to Reproduce:
1.gem install rhc
2.gem list
3.
  
Actual results:
both json_pure and json will be installed automatically on windows cygwin env. 

Expected results:
only json_pure should be used as dependency on Win.

Additional info:

Comment 1 Fotios Lindiakos 2012-04-20 15:22:55 UTC
Please retest with rhc gem version > 0.91.2, this was the first version where the conditional dependencies should work.

Comment 2 Meng Bo 2012-04-23 08:53:47 UTC
checked with rhc-0.91.5 and rhc-rest-0.1.3, both of them need json as dependency.

Comment 3 Fotios Lindiakos 2012-04-23 13:50:45 UTC
Are you installing rhc-rest manually? rhc-rest should not be installed with the new version of the rhc gem.

Comment 4 Meng Bo 2012-04-24 01:16:18 UTC
yes, i have tried to install rhc and rhc-rest separately,
and for rhc client, it will install json automatically, for rhc-rest, it will not be installed since missing dependency json.

Comment 5 Fotios Lindiakos 2012-04-27 19:23:27 UTC
rhc-rest does not need to be installed anymore, and rhc will remove it if it finds it. test by just installing rhc

Comment 6 Meng Bo 2012-04-28 03:18:18 UTC
Checked with latest rhc client rhc-0.92.2

Since the US2145 has been updated as follow:
====
The package should attempt to install json first, if it fails (or ENV['JSON_PURE'] is explicitly set), json_pure should be installed.
====

rhc can be installed successfully with json installed on Windows.
and rhc-rest will be removed during installation of rhc client.

Mark this bug as verified.


Note You need to log in before you can comment on or make changes to this bug.