Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81391 - Kernel Panic in Advanced Server 7.3 w/ Ultra 320 Controller
Summary: Kernel Panic in Advanced Server 7.3 w/ Ultra 320 Controller
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-08 21:32 UTC by Matt Dralle
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-25 14:29:07 UTC


Attachments (Terms of Use)

Description Matt Dralle 2003-01-08 21:32:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
Server and a SuperMicro dual-cpu 2.8ghz, hyperthreading motherboard with a 
Ultra320 SCSI controller built on.

http://adaptec-tic.adaptec.com/cgi-bin/adaptec_tic.cfg/php/enduser/std_adp.php?
p_faqid=4532&p_created=1034869839

Note that it says that "Red Hat is aware of the issue and is working on a fix 
for it"...

What is the resolution to this issue?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot the system
2.
3.
    

Actual Results:  About half way through the boot process, the kernel reports 
panic and that it can't find something about 8,1 and that the user should add a 
boot= line to somethign.

Expected Results:  Boot completes

Additional info:

The Adaptec website indicates that this is a "known issue" within Red Hat an 
that they are working on a fix.

Installing a PCI 2940u2 SCSI card in the system and putting the boot disk on it 
will result in the system booting fine.  i.e. the problem is definately related 
to the 320 SCSI controller (aic79xx?)

Comment 2 Tom Coughlan 2003-07-25 20:47:54 UTC
The early versions of the aic79xx driver had many problems.  The aic79xx driver
rev. 1.3.4 in the latest AS2.1 kernel errata (e.25) may solve the problem.  If
not, there is a newer rev. 1.3.10 available from the maintainer 

http://people.freebsd.org/~gibbs/linux/

We plan to update this driver in the next AS 2.1 errata.

Comment 3 Tom Coughlan 2004-08-25 14:29:07 UTC
No reply in over a year.  The current AS 2.1 errata has aic79xx v1.3.10. 
Assuming this fixed the problem.


Note You need to log in before you can comment on or make changes to this bug.