Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81374 - gnumeric in current Raw Hide won't start up
Summary: gnumeric in current Raw Hide won't start up
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 81480 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-08 16:45 UTC by Jonathan Kamens
Modified: 2016-11-24 15:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 18:05:14 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2003-01-08 16:45:53 UTC
My whole machine is current with respect to today's Raw Hide.

jik:~!34> rpm -q gnumeric
gnumeric-1.0.9-6
jik:~!35> rpm --verify gnumeric
jik:~!36> gnumeric
Bonobo-WARNING **: Syntax error in ''                                          
       

At this point it hangs.

Comment 1 Bill Nottingham 2003-01-10 05:15:33 UTC
*** Bug 81480 has been marked as a duplicate of this bug. ***

Comment 2 Havoc Pennington 2003-01-14 03:32:12 UTC
twaugh said it worked with newer libc/kernel. Please verify when 
the next beta comes out.

Comment 3 Jonathan Kamens 2003-01-14 09:04:39 UTC
With glibc-2.3.1-34 and the current Raw Hide kernel at work, gnumeric now starts
up.  However, at home with glibc-2.3.1-34 and a 2.4.20-ac2 kernel (i.e., no
NPTL), gnumeric continues to hang when I try to start it.


Comment 4 Jay Turner 2003-01-14 14:49:17 UTC
With the re0113.0 tree, gnumeric is working as expected:
gnumeric-1.0.12-1
kernel-2.4.20-2.14
glibc-2.3.1-34

However, going to push this issue back to assigned to get a ruling on the
behavior seen under a non-NPTL kernel.

Comment 5 Havoc Pennington 2003-01-14 15:07:06 UTC
Moving to glibc - I don't know if glibc is supposed to be working 
in this case or not.

Comment 6 Jonathan Kamens 2003-01-15 18:02:03 UTC
I am no longer convinced that this is a NPTL issue.  I saw gnumeric hang at work
again this morning, i.e., on the machine which has the NPTL kernel and glibc.  I
updated to the current Raw Hide and rebooted, and the hang went away.  I don't
know whether the reboot or the update is what cured the problem.


Comment 7 Jakub Jelinek 2003-01-15 18:05:14 UTC
Lately gnumeric was stuck with LD_ASSUME_KERNEL=2.2.5 because of libc+linuxthreads
bug, which ought to be fixed in glibc-2.3.1-36.


Note You need to log in before you can comment on or make changes to this bug.