Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81371 - neat forgets modem init-string
Summary: neat forgets modem init-string
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 77690 (view as bug list)
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2003-01-08 16:32 UTC by Tuomo Soini
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-05 14:25:01 UTC


Attachments (Terms of Use)
Wvdial.conf after first configuration (deleted)
2003-02-05 22:16 UTC, Tuomo Soini
no flags Details
Wvdial.conf after neat (deleted)
2003-02-05 22:21 UTC, Tuomo Soini
no flags Details

Description Tuomo Soini 2003-01-08 16:32:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When neat is used to configure modem connection it doesn't remember init string
which was defined last time. Save removes old init-string from /etc/wvdial.conf.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure modem connection, change init-string to working one. Save.
2.Restart neat, change other settings like ppp-options.
3.Save - init-string given first time is lost.
    

Actual Results:  When first configured everything worked as expected. Settings
were saved to /etc/wvdial.conf.

When procedure was done, only default Init1 = ATZ was found on wvdial.conf

Expected Results:  neat should have read Init3 string from /etc/wvdial.conf when
started.
So Inistring field should have been prefilled with previous value.

Additional info: Same bug is in neat on rh7.3.

Comment 1 Harald Hoyer 2003-02-05 12:59:49 UTC
hmm, worksforme... can you attach wvdial.conf (change user/pw, of course :)

Comment 2 Tuomo Soini 2003-02-05 22:16:10 UTC
Created attachment 89873 [details]
Wvdial.conf after first configuration

Comment 3 Tuomo Soini 2003-02-05 22:21:03 UTC
Created attachment 89874 [details]
Wvdial.conf after neat

1. Configure connection
2. Apply changes, exit neat
3. Start neat, select ppp0 for config, change _nothing_ initstring field is
empty so neat didn't read it from wvdial.conf as it should have done.
4. Apply changes - initstring is gone from wvdial.conf.

Comment 4 Harald Hoyer 2003-02-07 12:50:46 UTC
*** Bug 77690 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.