Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 813552 - [abrt] kernel: [170012.908386] WARNING: at lib/list_debug.c:30 __list_add+0x8f/0xa0()
Summary: [abrt] kernel: [170012.908386] WARNING: at lib/list_debug.c:30 __list_add+0x8...
Keywords:
Status: CLOSED DUPLICATE of bug 807748
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8288d03885c5f7e738fedd0b254...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-17 20:35 UTC by Andy Freeland
Modified: 2012-07-10 21:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-10 21:54:03 UTC


Attachments (Terms of Use)

Description Andy Freeland 2012-04-17 20:35:06 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.1-3.fc16.x86_64 root=UUID=b0544ae6-afc1-4f10-a33e-7ec463ac3cc8 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
kernel:         3.3.1-3.fc16.x86_64
reason:         [170012.908386] WARNING: at lib/list_debug.c:30 __list_add+0x8f/0xa0()
time:           Tue 17 Apr 2012 03:31:38 PM CDT

backtrace:
:[170012.908386] WARNING: at lib/list_debug.c:30 __list_add+0x8f/0xa0()
:[170012.908391] Hardware name: 2516CTO
:[170012.908395] list_add corruption. prev->next should be next (ffff880109ea30f0), but was ffff880109ea00e0. (prev=ffff880109ea00e0).
:[170012.908399] Modules linked in: iwlwifi(-) mac80211 cfg80211 des_generic md4 nls_utf8 cifs fscache bluetooth cpufreq_stats hdaps(O) tp_smapi(O) thinkpad_ec(O) usb_storage ppdev parport_pc lp parport fuse 8021q garp stp llc fcoe lockd libfcoe libfc scsi_transport_fc scsi_tgt be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi input_polldev sunrpc snd_hda_codec_hdmi snd_hda_codec_conexant uinput uvcvideo snd_hda_intel videobuf2_core snd_hda_codec videodev media snd_hwdep v4l2_compat_ioctl32 snd_seq videobuf2_vmalloc videobuf2_memops snd_seq_device snd_pcm thinkpad_acpi snd_timer arc4 tpm_tis snd i2c_i801 tpm tpm_bios soundcore joydev iTCO_wdt snd_page_alloc e1000e microcode iTCO_vendor_support intel_ips rfkill binfmt_misc firewire_ohci ata_generic firewire_core pata_acpi mxm_wmi crc_itu_t sdhci_pci sdhci mmc_core pata_jmicron wmi i915 drm_kms_h
:elper drm i2c_algo_bit i2c_core video [last unloaded: cfg80211]
:[170012.908502] Pid: 16368, comm: modprobe Tainted: G        W  O 3.3.1-3.fc16.x86_64 #1
:[170012.908505] Call Trace:
:[170012.908513]  [<ffffffff8105798f>] warn_slowpath_common+0x7f/0xc0
:[170012.908517]  [<ffffffff81057a86>] warn_slowpath_fmt+0x46/0x50
:[170012.908528]  [<ffffffff812d47ff>] __list_add+0x8f/0xa0
:[170012.908550]  [<ffffffffa0706683>] iwl_trans_rxq_free_rx_bufs+0x93/0xf0 [iwlwifi]
:[170012.908568]  [<ffffffffa0707d8a>] iwl_trans_pcie_free+0x4a/0x2b0 [iwlwifi]
:[170012.908587]  [<ffffffffa0717cfb>] iwl_remove+0x102/0x126 [iwlwifi]
:[170012.908604]  [<ffffffffa0717d46>] iwl_pci_remove+0x27/0x67 [iwlwifi]
:[170012.908611]  [<ffffffff812e80b6>] pci_device_remove+0x46/0x110
:[170012.908621]  [<ffffffff813a144c>] __device_release_driver+0x7c/0xe0
:[170012.908628]  [<ffffffff813a1d28>] driver_detach+0xb8/0xc0
:[170012.908635]  [<ffffffff813a128a>] bus_remove_driver+0x8a/0x100
:[170012.908641]  [<ffffffff813a24e2>] driver_unregister+0x62/0xa0
:[170012.908647]  [<ffffffff812e76f4>] pci_unregister_driver+0x44/0xa0
:[170012.908664]  [<ffffffffa0705f95>] iwl_pci_unregister_driver+0x15/0x20 [iwlwifi]
:[170012.908680]  [<ffffffffa0717d8f>] iwl_exit+0x9/0x27a [iwlwifi]
:[170012.908688]  [<ffffffff810b6396>] sys_delete_module+0x1a6/0x2b0
:[170012.908696]  [<ffffffff810d322c>] ? __audit_syscall_entry+0xcc/0x310
:[170012.908704]  [<ffffffff815fbfe9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 0947c899-ef1f-48c7-9495-5689c2fcdc94
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 5319.68
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5 CPU       M 560  @ 2.67GHz
:CPU Stepping: 5
:CPU Family: 6
:CPU Model Num: 37
:Number of CPUs: 4
:CPU Speed: 2667
:System Memory: 7783
:System Swap: 7511
:Vendor: LENOVO
:System: 2516CTO ThinkPad T410
:Form factor: Notebook
:Kernel: 3.3.1-3.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59426:6058:8499) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4480:57904:6058:8500) pci, None, BASE, Memory Stick Host Controller
:(4480:59442:6058:8502) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(32902:11362:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture Generic Non-core Registers
:(32902:11521:6058:8598) pci, None, HOST/PCI, Core Processor QuickPath Architecture System Address Decoder
:(32902:68:6058:8595) pci, agpgart-intel, HOST/PCI, Core Processor DRAM Controller
:(32902:11536:6058:8598) pci, None, HOST/PCI, Core Processor QPI Link 0
:(32902:11537:6058:8598) pci, None, HOST/PCI, Core Processor QPI Physical 0
:(32902:11538:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:11539:6058:8598) pci, None, HOST/PCI, Core Processor Reserved
:(32902:15152:6058:8551) pci, i801_smbus, SERIAL, 5 Series/3400 Series Chipset SMBus Controller
:(32902:15151:6058:8552) pci, ahci, STORAGE, 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
:(32902:15111:6058:8550) pci, None, PCI/ISA, Mobile 5 Series Chipset LPC Interface Controller
:(32902:15154:6058:8592) pci, intel ips, NONE, 5 Series/3400 Series Chipset Thermal Subsystem
:(32902:4330:6058:8531) pci, e1000e, ETHERNET, 82577LM Gigabit Network Connection
:(32902:9288:6058:8549) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:15164:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15156:6058:8547) pci, ehci_hcd, USB, 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
:(32902:15204:6058:8543) pci, None, SIMPLE, 5 Series/3400 Series Chipset HECI Controller
:(32902:16952:32902:4369) pci, iwlwifi, NETWORK, Centrino Ultimate-N 6300 3x3 AGN
:(32902:70:6058:8662) pci, i915, VIDEO, Core Processor Integrated Graphics Controller
:(32902:15176:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 4
:(32902:15170:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 1
:(32902:15172:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 2
:(32902:15178:6058:8548) pci, pcieport, PCI/PCI, 5 Series/3400 Series Chipset PCI Express Root Port 5
:(32902:15190:6058:8542) pci, snd_hda_intel, MULTIMEDIA, 5 Series/3400 Series Chipset High Definition Audio
:(6523:9059:6523:9059) pci, pata_jmicron, STORAGE, JMB362/JMB363 Serial ATA Controller
:(6523:9059:6523:9059) pci, ahci, STORAGE, JMB362/JMB363 Serial ATA Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sdb1 / ext4 4096 4096 2617554 503300 477093 655360 349128 349128
:/dev/sda5 /var ext4 4096 4096 1568149 1124689 1046059 393216 364020 364020
:/dev/sda4 WITHHELD ext3 4096 4096 104780664 3558951 3558951 26615808 26572499 26572499
:/dev/sda1 /boot ext4 1024 1024 517957 417328 391268 130560 130281 130281
:/dev/sdb3 /home ext4 4096 4096 8636917 2631373 2631373 2166640 1984196 1984196
:

Comment 1 Josh Boyer 2012-04-17 20:42:46 UTC
If you can recreate this without the external modules loaded, that would be appreciated.

Comment 2 Andy Freeland 2012-04-17 20:54:58 UTC
I can try running without tp_smapi, but I have no idea what caused it.

Comment 3 John W. Linville 2012-04-18 14:22:31 UTC
It looks like iwlwifi is mismanaging its list of rx_bufs -- hitting the second WARN below, FWIW...

void __list_add(struct list_head *new,
                              struct list_head *prev,
                              struct list_head *next)
{
        WARN(next->prev != prev,
                "list_add corruption. next->prev should be "
                "prev (%p), but was %p. (next=%p).\n",
                prev, next->prev, next);
        WARN(prev->next != next,
                "list_add corruption. prev->next should be "
                "next (%p), but was %p. (prev=%p).\n",
                next, prev->next, prev);
        next->prev = new;
        new->next = next;
        new->prev = prev;
        prev->next = new;
}

Comment 4 Dave Jones 2012-07-10 21:54:03 UTC

*** This bug has been marked as a duplicate of bug 807748 ***


Note You need to log in before you can comment on or make changes to this bug.