Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 813349 - Don't try to connect automatically to wifi network which we've failed to connect to
Summary: Don't try to connect automatically to wifi network which we've failed to conn...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-17 14:42 UTC by Matěj Cepl
Modified: 2014-06-13 09:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 09:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matěj Cepl 2012-04-17 14:42:41 UTC
Description of problem:
I've came to the office and connected my notebook to the Ethernet wired connection. I don't recall I would ever click on the one particular AP, but I get now periodically (every minute or so) password prompt for that wifi. Although I have many many other wifi's around (the office is in the center of Prague), NM still asks only about this one.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.4-3.git20120403.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
being asked for wifi, even though connected via wired connection
constantly being prompt for wifi which I don't want

Expected results:
1) when on wired connection, don't try wifi at all
2) when wifi connection is once rejected, don't try to automatically connect to it.

Comment 1 Zhouping Liu 2012-07-13 03:52:26 UTC
I also hit the issues.

In my wireless lists, there are lots of wifi options, but when I try to connect one, it failed without any responds, it should pop up a box to require the wifi's password.
also I try to do it in 'Network Setting', but whatever I choose which in 'Network Name' combobox, it always empty or 'Other...'.

my NM version is the same, but os is the latest rhel7
[root@zhouping zliu]# rpm -q NetworkManager
NetworkManager-0.9.4-3.git20120403.el7.x86_64

Thanks,
Zhouping

Comment 3 Jirka Klimes 2012-11-12 13:14:17 UTC
That's been fixed by this commit:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=ccfe5fec8d1c1038467e4a56656d8f90bc94d2ed

It is contained in the latest package:
NetworkManager-0.9.7.0-6.git20121004.el7

Comment 4 Vladimir Benes 2013-01-16 16:54:05 UTC
seems to be working well now
-> VERIFIED

Comment 5 Ludek Smid 2014-06-13 09:42:07 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.