Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81323 - redhat-config-packages crashes on startup with error message.
Summary: redhat-config-packages crashes on startup with error message.
Keywords:
Status: CLOSED DUPLICATE of bug 80283
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-08 02:55 UTC by safedin kajosaj
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:00 UTC


Attachments (Terms of Use)

Description safedin kajosaj 2003-01-08 02:55:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Trying to start up redhat-config-packages gives error messages, and crashes. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.on command lineL redhat-packages-config
2. Message pops up giving error message. 'Unknown Error'
3.
    

Actual Results:  crashed

Expected Results:  update system...

Additional info:

Tried the version in rawhide (1.1.4) and still get this error message.

[root@localhost safedin]# redhat-config-packages

(MainWindow.py:4969): GLib-GObject-WARNING **: invalid uninstantiatable type
`gint' in cast to `GtkObject'

(MainWindow.py:4969): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `gint'

Uninstalling and reinstall version still causes error

[root@localhost safedin]# redhat-config-packages

(MainWindow.py:5002): GLib-GObject-WARNING **: invalid uninstantiatable type
`gint' in cast to `GtkObject'

(MainWindow.py:5002): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `gint'

(MainWindow.py:5002): GLib-GObject-CRITICAL **: file gsignal.c: line 2056
(g_signal_handlers_destroy): assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
[root@localhost safedin]#
(MainWindow.py:4969): GLib-GObject-CRITICAL **: file gsignal.c: line 2056
(g_signal_handlers_destroy): assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
[root@localhost safedin]# redhat-config-packages

(MainWindow.py:4991): GLib-GObject-WARNING **: invalid uninstantiatable type
`gint' in cast to `GtkObject'

(MainWindow.py:4991): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `gint'

(MainWindow.py:4991): GLib-GObject-CRITICAL **: file gsignal.c: line 2056
(g_signal_handlers_destroy): assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
[root@localhost safedin]#

Removing that version and using up2date to install version that came with Pheobe
gives

[root@localhost safedin]# redhat-config-packages

(MainWindow.py:5010): GLib-GObject-WARNING **: invalid uninstantiatable type
`gint' in cast to `GtkObject'

(MainWindow.py:5010): GLib-GObject-WARNING **: instance of invalid
non-instantiatable type `gint'

(MainWindow.py:5010): GLib-GObject-CRITICAL **: file gsignal.c: line 2056
(g_signal_handlers_destroy): assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
[root@localhost safedin]#

Comment 1 Jeremy Katz 2003-01-08 04:00:47 UTC
You need to update pygtk2/gnome-python2 as well 

*** This bug has been marked as a duplicate of 80283 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.