Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81318 - spamassassin 2.43 depends on MIME::Body
Summary: spamassassin 2.43 depends on MIME::Body
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-08 00:21 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 14:47:40 UTC


Attachments (Terms of Use)
SPEC file for MIMEtools to provide MIME::Body (deleted)
2003-01-08 00:24 UTC, Need Real Name
no flags Details
SPEC file for MailTools to provide Mail::Internet (deleted)
2003-01-08 00:25 UTC, Need Real Name
no flags Details
SPEC file for IO-stringy to provide IO::Scalar (deleted)
2003-01-08 00:26 UTC, Need Real Name
no flags Details
Updated patch for init scipt (deleted)
2003-01-10 08:19 UTC, Need Real Name
no flags Details | Diff
SPEC file for an unoffical "spamassassin 2.43-11" which uses the above patch (deleted)
2003-01-10 08:21 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-01-08 00:21:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Description of problem:
The SPEC file for 2.43-6 turned off the RPM internal dep generator.  In SPEC
file 2.43-10 the RPM internal dep generator is turned back on and detects that
MIME::Body is needed but there is no RawHide packages which provide this.

I have attached SPEC files for:
  perl-MIMEtools  (provides MIME::Body for spamassassin)
  perl-MailTools  (provides Mail::Internet for MIMEtools)
  perl-IO-stringy (provides IO::Scalar for MIMEtools)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install spamassassin-2.43-10.src.rpm on a RH 8.0 system
2.rpmbuild -ba spamassassin.spec
3.rpm -Uvh spamassassin-2.43-10.i386.rpm


Actual Results:  Complains that it needs MIME::Body

Expected Results:  Expected all complaints for dependancies to be handled by
additional packages available in RawHide.

Additional info:

Comment 1 Need Real Name 2003-01-08 00:24:04 UTC
Created attachment 89200 [details]
SPEC file for MIMEtools to provide MIME::Body

Comment 2 Need Real Name 2003-01-08 00:25:03 UTC
Created attachment 89201 [details]
SPEC file for MailTools to provide Mail::Internet

Comment 3 Need Real Name 2003-01-08 00:26:33 UTC
Created attachment 89202 [details]
SPEC file for IO-stringy to provide IO::Scalar

Comment 4 Need Real Name 2003-01-08 08:34:14 UTC
Why am I blocked from viewing bug #79578?

Comment 5 Need Real Name 2003-01-10 08:17:26 UTC
Attached is a modified spamassassin-2.43-init.patch and SPEC file.  

This modification is intended to address two issues:

- The 2.43-10 package contains an init script which attempt to use
/etc/sysconfig/spamd and ignores the actual script of /etc/sysconfig/spamassassin

- http://spamassassin.sourceforge.net/dist/INSTALL states a known performance
issue with Unicode support in Perl 5.8.0.  The patch modifies the script to
include the recommended "export LANG=en_US" before launching the spamd.  My
expierence has been that the average processing time dropped from 30 seconds to
around 6 seconds per email with this modification.


Comment 6 Need Real Name 2003-01-10 08:19:45 UTC
Created attachment 89284 [details]
Updated patch for init scipt

Comment 7 Need Real Name 2003-01-10 08:21:56 UTC
Created attachment 89285 [details]
SPEC file for an unoffical "spamassassin 2.43-11" which uses the above patch

Comment 8 Chip Turner 2003-02-08 21:11:07 UTC
check rawhide, spamassassin is upgraded to 2.44 and I've repaired the dependency
issues so that they aren't present anymore

Comment 9 Jay Turner 2003-02-10 14:47:40 UTC
Closing out.


Note You need to log in before you can comment on or make changes to this bug.