Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 813 - /etc/login.defs and chfn option with users name
Summary: /etc/login.defs and chfn option with users name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: shadow-utils
Version: 1.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-13 04:11 UTC by stewart
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-23 19:11:24 UTC


Attachments (Terms of Use)

Description stewart 1999-01-13 04:11:42 UTC
This has bothered me for a while... and it would be nice to
see this as being a configurable option.  I don't want my
regular users to be able to change their name.  They can
contact root if they have a valid reason.  But they should
be able to change the rest of the info.

Either way this is just a little documentation complaint.

The file /etc/login.defs contains this option:
#
# Require password before chfn/chsh can make any changes.
#
CHFN_AUTH               yes

# Don't allow users to change their "real name" using chfn.
#
CHFN_RESTRICT           yes

But they do not work.  Namely the problem is that
/etc/login.defs comes from shadow-utils, whereas chfn comes
from util-linux.  So for now I guess removing these three
lines would be OK.  (The first should be on, all the time
anyway.)

	[root@zarg /etc]# rpm -qf /etc/login.defs
	shadow-utils-980403-5a
	[root@zarg /etc]# rpm -qf /usr/bin/chfn
	util-linux-2.9-6c

Comment 1 Cristian Gafton 1999-03-19 18:56:59 UTC
We are not using the login.defs file to control the behavior of the
chfn and chsh utilities

Comment 2 stewart 1999-03-19 20:19:59 UTC
Ok, then can the references to chfn/chsh be removed from
shadow-970616.login.defs (/etc/login.defs).  If it is not used it just
creates confusion if it is in the file.

Comment 3 Preston Brown 1999-03-23 19:11:59 UTC
fixed in shadow-utils-980403-8 and later.


Note You need to log in before you can comment on or make changes to this bug.