Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81297 - tcl RPM in Raw Hide doesn't know what libraries it provides
Summary: tcl RPM in Raw Hide doesn't know what libraries it provides
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
: 80967 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-07 19:24 UTC by Jonathan Kamens
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 00:30:41 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2003-01-07 19:24:05 UTC
jik:/var/tmp/rpms!167> rpm -q --provides -p tcl-8.3.5-79.i386.rpm 
tcl = 8.3.5-79
jik:/var/tmp/rpms!168> rpm -q -l -p tcl-8.3.5-79.i386.rpm | grep libtcl
/usr/lib/libtcl.so
/usr/lib/libtcl8.3.so
/usr/lib/libtclstub8.3.a
jik:/var/tmp/rpms!169>

Comment 1 Bill Nottingham 2003-01-08 05:25:28 UTC
This is probably because the libraries don't have SONAMEs.

Comment 3 Jens Petersen 2003-01-16 08:51:43 UTC
Thanks for the report.  This was caused by a change in behaviour of rpmbuild.
All the libs in tcltk should now have DT_SONAME defined in 8.3.5-84.

Comment 4 Jay Turner 2003-01-21 00:30:41 UTC
Getting this now:
rpm -qp --provides tcl-8.3.5-85.i386.rpm
libtcl8.3.so
tcl = 8.3.5-85



Note You need to log in before you can comment on or make changes to this bug.