Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81278 - fr-latin1 (french) keyboard in text mode doesn't print correctly french symbols and Euro
Summary: fr-latin1 (french) keyboard in text mode doesn't print correctly french symbo...
Keywords:
Status: CLOSED DUPLICATE of bug 75811
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-07 15:13 UTC by Olivier de Liocourt
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:59 UTC


Attachments (Terms of Use)

Description Olivier de Liocourt 2003-01-07 15:13:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
in text mode, on TTY1 for example, keyboard set as fr-latin1, choice of the
language in the install program in French, doesn't write Euro symbol (AltGr+e),
and some french symbols too (�, �, �)
Backspace touch delete a part of the prompt line ([root@liocourt-test root]#
becomes [root@liocou )

Under X, no problem.

The same problem is existing on 8.0 (Psyche)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log in on tty1
2.choose your keyboard as fr-latin1 with kbdconfig
3.type <alt Gr> + e -> gives e and not �
4. type ^ and e after -> gives nothing printed on the screen, should give �

    

Actual Results:  <alt Gr> + e -> gives e and not �
typing ^ and e after -> gives nothing printed on the screen, should give a "e"
with a "^" on it. The same for "a" and "u"

Expected Results:  � symbol
�, �, �

Additional info:

keyboard mapping problem, or usage of UTF8 instead of ASCII, or font with
symbols not implemented maybe
I tried to change the font, nothing better, I tried to use the console-tools
package of the 7.3, replacing UTF with ASCII and choosing another font, it works.

Comment 1 Eido Inoue 2003-02-19 21:28:05 UTC
according to the kbd faq in /usr/share, the euro and compose maps are not loaded
by default. look at the euro1.inc and euro2.inc and the compose inc maps in
/lib/kbd/keymaps/include and /lib/kbd/keymaps/i386/include and use loadkeys to
include them.

Comment 2 Bastien Nocera 2003-02-24 14:24:22 UTC
LANG=en_GB.UTF-8

LANG=fr_FR.UTF-8 ls -l shows accent properly (not a font problem)

keymap is "us-acentos". I loaded /lib/kbd/keymaps/include/compose.latin1 by hand
with loadkeys. The compose key is "Ctrl+." (see output of "dumpkeys | grep -C4
Compose").

Try getting an "e acute" accentuated character with "Compose + ' + e". I get
nothing printed on the screen.

uname tells me the kernel is 2.4.20-2.30 from rawhide. Problem is reproduceable
with an up to date kernel from 8.0.

Comment 4 Miloslav Trmac 2003-02-24 19:49:53 UTC
Linux VT code doesn't support multibyte (i.e. UTF-8) results of
compose or dead keys *at all*.
So this is a duplicate of 75811. I unfortunately didn't have
time to fullfil the promise there.

Comment 5 Bill Nottingham 2003-03-12 17:13:48 UTC

*** This bug has been marked as a duplicate of 75811 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:50:59 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.