Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81273 - Fonts not set to iso-8859-2
Summary: Fonts not set to iso-8859-2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: evolution
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 88253 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-07 14:17 UTC by Miloslav Trmac
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-29 20:43:33 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-01-07 14:17:03 UTC
Description of problem:
Clean install of Phoebe in Czech, cs_CZ.UTF-8
When Evolution starts, it uses ISO-8859-1 fonts and replaces all
ISO-8859-2 chars by underscores. Some of the problems can be
fixed by selecting ISO-8859-2 encoding for screen fonts in
the settings dialog (note that printing fonts already have
ISO-8859-2), but some (e.g. fonts used in the summary view)
don't have a GUI way to change the encoding.

Another bug: In the icon listbox at the left of the settings dialog,
the labels are cut off after accented characters (e.g.
Nastaven instead of Nastaven&icaron; )

Version-Release number of selected component (if applicable):
evolution-1.2.1-2

Comment 1 Jeremy Katz 2003-01-23 03:53:52 UTC
I'm not seeing this here -- did you have settings leftover from a previous release?

Comment 2 Miloslav Trmac 2003-01-23 09:11:43 UTC
No, clean install with new /home.
A screenshot showing one the problems in the summary view is at
http://www.linuxzone.cz/pictures/Plocha.gif
(Moje po_asi etc).
[I haven't found a way to set up *this* font right. Similar underscores
appear in the config dialog and elsewhere, and some of them can be fixed
as described above].
I'll try to attach more tomorrow, and try the second beta in a week or so.

Comment 3 Martin Sitar 2003-01-24 12:38:58 UTC
The same problem in clean install of Red Hat Linux release 8.0.93 (Phoebe) (beta2)
Package evolution-1.2.1-4

Comment 4 Jeremy Katz 2003-02-10 03:16:55 UTC
Does this seem better with gtkhtml-1.1.8-1 and evolution 1.2.2 from rawhide?

Comment 5 Martin Sitar 2003-02-10 08:26:39 UTC
Yes, fonts look pretty good with this release of evolution and gtkhtml.
I haven`t find any other bug yet .. 

Comment 6 Martin Sitar 2003-02-10 08:49:28 UTC
Additionally I found one bug in Settings menu fonts. 
<a href="http://hch.internet.cz/download/sets.png">screenshot</a>


Comment 7 Martin Sitar 2003-02-11 08:40:40 UTC
With gtkhtml-1.1.8-3.i386.rpm from todays rawhide is everything once again wrong.
ISO-8859-2 encoding in summary page and Subject of messages are with underscores
without appropriate chracter.


Comment 8 Miloslav Trmac 2003-02-14 20:39:01 UTC
clean phoebe 8.0.93 install in cs_CZ.UTF-8 + evolution-1.2.2-1, gtkhtml-1.1.8-3:
- the default *screen* font is still 8859-1;
  note that default default *print* font is 8859-2. IIRC, the defaults (-1 for
  screen, -2 for print) haven't changed
- before changing the default, non-8859-1 chars show as _
- after changing the default, thinks look pretty much OK,
  even the summary view (this is better since my previous report).
  The only problem I have noticed is the icon bar in the Settings dialog
  (see the second screenshot link from Martin)

Comment 9 Jeremy Katz 2003-04-09 00:36:09 UTC
*** Bug 88253 has been marked as a duplicate of this bug. ***

Comment 10 Jeremy Katz 2003-06-29 20:43:33 UTC
UTF-8 should be handled sanely with 1.4.x in rawhide.

Comment 11 Stephane Jourdan 2003-06-29 21:31:24 UTC
I confirm Evolution 1.4 doesn't have this problem anymore, I didn't test the
current rawhide version but the version available at the maintainer's homepage
on people.redhat.com/~katzj on both clean and old RH9 installs.

That's good news !  


Note You need to log in before you can comment on or make changes to this bug.