Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81243 - Installer hangs when no (PS/2) mouse has been found.
Summary: Installer hangs when no (PS/2) mouse has been found.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-07 00:15 UTC by Peter van Egdom
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-26 17:03:46 UTC


Attachments (Terms of Use)
Output of "dmesg" (deleted)
2003-01-07 22:38 UTC, Peter van Egdom
no flags Details
Output of "lsdev" (deleted)
2003-01-07 22:39 UTC, Peter van Egdom
no flags Details
Output of "lspci -v" (deleted)
2003-01-07 22:41 UTC, Peter van Egdom
no flags Details
Output of "cat /proc/ioports" (deleted)
2003-01-07 22:41 UTC, Peter van Egdom
no flags Details
hardware configuration of machine where installator hangs without ps/2 mouse (deleted)
2003-02-16 21:20 UTC, Michal Ambroz
no flags Details

Description Peter van Egdom 2003-01-07 00:15:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:

On my testmachine, a HP NetServer LD Pro (Pentium Pro 166, 64 MB class) Anaconda
did not find a PS/2 mouse (it *does* have one, also a PS/2 keyboard). 

When it said it that it did not find a mouse, it (Anaconda) hung.

(well it appeared that it hung,  the keyboard was not responding to keypresses
and also the capslock key did not turn on the led on that key, same situation
for the numlock key).

After powering down the machine using the power button I used "linux noprobe",
but that did not help, it still crashed while asking which mouse I got.

Some information :

This NetServer did not have a well enough supported video card for a graphical
installation. 

I tried installing Phoebe 8.0.92 via NFS using the 2 bootfloppies.

This machine did not have problems running Red Hat 7.2. At the moment it is
still running RH 7.2, because the crashed Phoebe installation had not reached
partitioning yet.

I'll be happy to report more information - if required - using the tools
provided with Red Hat 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (reproduced twice)
2. Install Phoebe 8.0.92 via NFS in textmode (no graphical mode supported).
3.
    

Actual Results:  
Anaconda 'froze' while probing for mouse (no capslock, numlock, or scroll-lock
keypress triggered corresponding leds).

With "linux noprobe" Anaconda still froze asking which PS/2 mouse I got.


Expected Results:  
Anaconda should not freeze during the mouse probe / mouse selection screen.

Additional info:

Phoebe 8.0.92

Comment 1 Bill Nottingham 2003-01-07 01:12:07 UTC
What chipset?

Comment 2 Peter van Egdom 2003-01-07 22:35:11 UTC
I will attach some output from Red Hat 7.2 on this machine.

Comment 3 Peter van Egdom 2003-01-07 22:38:35 UTC
Created attachment 89196 [details]
Output of "dmesg"

Comment 4 Peter van Egdom 2003-01-07 22:39:38 UTC
Created attachment 89197 [details]
Output of "lsdev"

Comment 5 Peter van Egdom 2003-01-07 22:41:00 UTC
Created attachment 89198 [details]
Output of "lspci -v"

Comment 6 Peter van Egdom 2003-01-07 22:41:50 UTC
Created attachment 89199 [details]
Output of "cat /proc/ioports"

Comment 7 Nathan G. Grennan 2003-01-08 06:17:38 UTC
This bug is very similar to #80293, just that for some reason it doesn't detect
his ps/2 mouse when it is there.

Comment 8 Michael Fulbright 2003-01-08 20:09:51 UTC
Most certainly a kernel issue.

Comment 9 Michal Ambroz 2003-02-16 21:11:43 UTC
I have experienced the same behaviuor during (anaconda) AND after installation
(kudzu).

When I tried textmode installation (from local CDROM), testing of media was OK,
but then when continued it always hangs without PS/2 mouse.

I have got COM1 mouse and tried even without mouse - it always hanged.
When I attached PS/2 mouse of the same type (Genius NetScroll+) everything
worked just fine.

After installing kudzu seems to have the same behaviour - it always hangs the
keyboard. It is not possible to enter anything, switch to other virtual console
or even use of the ALT-SysRq-k combination doesn't kill the application. Only
way is to kill it remotely via ssh or telnet.

Whe I run the kudzu remotely nothing strange happens.

Michal Ambroz

Comment 10 Michal Ambroz 2003-02-16 21:20:52 UTC
Created attachment 90117 [details]
hardware configuration of machine where installator hangs without ps/2 mouse

hardware configuration of machine where installator and kudzu hangs without
ps/2 mouse

Comment 11 Michal Ambroz 2003-02-22 21:41:03 UTC
Problem with Kudzu hangup withouth PS/2 mouse is gone with kudzu version from
Phoebe 8.0.94. 

Sorry I don't have a full cdset of 8.0.94 to test the installator too.

Comment 12 Peter van Egdom 2003-04-26 17:03:46 UTC
Successfully installed Red Hat Linux release 9 (Shrike) from scratch on this PC.

The problem with the keyboard locking up did not occur.

I tested the installation of Shrike twice, one time with a PS/2 mouse attached
and one time without a mouse attached to the machine.

Resolving bug with resolution CURRENTRELEASE.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.