Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81239 - cipe interface preventing route from going into kernel
Summary: cipe interface preventing route from going into kernel
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cipe
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
: 81241 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 23:34 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-24 02:20:00 UTC


Attachments (Terms of Use)

Description Ted Kaczmarek 2003-01-06 23:34:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030104

Description of problem:
Route will not install if cipe interface ip is in same address space.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Bring up cipe inteface on HOST A with ip of 192.168.200.1 and HOST B peer of
192.168.200.2
2.Have bgp peer HOST A send 192.168.0.0/16 route to HOST B
3.Confirm route in bgp table, not in kernel routing table
    

Actual Results:  Route of 192.168.0.0/16 is not put in kernel routing table.

Expected Results:  Route of 192.168.0.0/16 is put into kernel routing table.

Additional info:

As a test instead of sending the /16 which overlaps the cipe interface, I sent
it as a /17, that route does get put into the kernel routing table. Wasn't sure
if this is kernel or cipe, but it is definelty cipe related. I even advertised
the same route from another peer (Router C)across the ethernet0 and saw the same
issue.

Will attach a diagram as well.

Comment 1 Ted Kaczmarek 2003-01-06 23:50:39 UTC
*** Bug 81241 has been marked as a duplicate of this bug. ***

Comment 2 Ted Kaczmarek 2003-02-24 02:20:00 UTC
This problem does not occur with 2.4.18-24.8.0, no point in leaving this open.


Note You need to log in before you can comment on or make changes to this bug.