Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81211 - After boot diskette creation fails, all subsequent attempts fail too
Summary: After boot diskette creation fails, all subsequent attempts fail too
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-06 20:11 UTC by Miloslav Trmac
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:50:55 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-01-06 20:11:09 UTC
Version-Release number of selected component (if applicable):
anaconda-8.0.92-8

How Reproducible:
haven't tried from 1., but did from .2

Steps to Reproduce:
1.When asked to create a boot diskette, insert one with bad blocks
2.Replace it with a good diskette
3.Try again
    
Actual results:
After an error box about creation of the diskette (with very general
message and no error output on any of the VTs AFAICS, by the way),
all subsequent attempts to create a boot diskette fail almost
immediately (just about half a second of floppy head seeking).

Comment 1 Bill Nottingham 2003-01-06 22:54:39 UTC
Hm, are we unmounting the image correctly in these cases?

Comment 2 Jeremy Katz 2003-01-08 21:05:18 UTC
Looks like we are, and I haven't seen this (and I have tried with bad floppies).
 Do you get any error messages on tty4?  

Comment 3 Miloslav Trmac 2003-01-14 12:05:00 UTC
Reproduced (badblocks shows bad blocks from sector 8 or 12, not from
the first) on a very minimal install (minimal and then deselect all
packages in individual package selection) using Czech language.

No errors anywhere, except for a dump of 3 lines (blocks for
kernel, initrd,... IIRC). These lines get added every time,
but the floppy head just moves a few times and creation immediately
fails.

Comment 4 Jeremy Katz 2003-02-05 22:55:08 UTC
This should be happier with the changes to mkbootdisk and the rest of the boot
disk creation code.

Comment 5 Brent Fox 2003-05-25 14:50:55 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.