Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81209 - (SCHEDULER ?)Sound distortion on VIA 686b
Summary: (SCHEDULER ?)Sound distortion on VIA 686b
Keywords:
Status: CLOSED DUPLICATE of bug 100918
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 20:00 UTC by Miloslav Trmac
Modified: 2013-07-03 02:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-01-06 20:00:38 UTC
Description of problem:
This is one of the bug reports that are unlikely to get fixed,
but anyhow:
kernel-2.4.20-2.2

Steps to Reproduce:
1. install gnome, redhat-artwork, ... (HW described below)
2. ogg123 /usr/share/redhat-credits.ogg
3. Ctrl-Alt-Shift-triple-click the desktop
    
Expected results: (8.0)
The sound is same in both cases, including volume and the silence at start.

Actual results:
In step 3), I hear clicking sounds at start (seem to be synchronized
with desktop redrawing). When the real music starts, it is
very distorted and LOUD.

Additional info:
driver via82cxxx_audio,
lspci gives VIA VT82C656 rev. 50, subsystem ID: ECS, unknown product 0987

Comment 1 Alan Cox 2003-01-06 22:15:43 UTC
Clicking may be X traffic. Heavy video traffic on some boxes causes that.
Playing with BIOS PCI settings can sometimes help as can setting card specific
options in X.

The volume one isnt the kernel - that sounds like something is touching mixer
settings in the 
easter egg.


Comment 2 Miloslav Trmac 2003-01-07 10:26:26 UTC
Sorry, I forgot to say explicitly that in RHL 8.0 there is no such problem, and redhat-credits apparently hasn't changed.

Comment 3 Havoc Pennington 2003-01-14 21:43:40 UTC
Bug currently seems to be on kernel but assigned to me, I don't know 
its history but current situation makes no sense so reassigning.

Comment 4 Miloslav Trmac 2003-04-07 20:14:37 UTC
Still the same in final.
Strange thing is that starting
    ogg123 /usr/share/redhat-credigs.ogg & /usr/libexec/redhat-credits
(or starting ogg123 longer before starting redhat-credits)
results in perfect sound.

Comment 5 Alan Cox 2003-06-05 13:52:32 UTC
Looks like an O(1) scheduler interaction example


Comment 6 Warren Togami 2003-06-08 20:03:42 UTC
I think this behavior became far worse with recent (1995+) rawhide kernels,
although I am not entirely sure if this is the same behavior that I am seeing.

Comment 7 Miloslav Trmac 2003-06-09 08:01:32 UTC
FWIW, neither of these helped:
* renicing ogg123 to -20
* renicing ogg123 and esd to -20
* the above + renicing redhat-credits to +19
* the above + renicing X to +19

Swhat is a sound card supposed to do if it doesn't get data?
Is it supposed to
* be silent
* repeat last sample
* output random noise
?

What I actually get is quite different from (cat /dev/urandom > /dev/dsp),
(most noticeable are regular clicks), but it is certainly not similar to
the silence at the start of the ogg file.

Comment 8 Miloslav Trmac 2003-07-27 21:23:07 UTC
Bug in redhat-credits actually, causing ogg123 to dump its real-time console
output to /dev/dsp.

*** This bug has been marked as a duplicate of 100918 ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.