Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81205 - 'write translatable strings' is broken
Summary: 'write translatable strings' is broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 19:21 UTC by Tim Waugh
Modified: 2005-10-31 22:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-08 08:30:53 UTC


Attachments (Terms of Use)

Description Tim Waugh 2003-01-06 19:21:02 UTC
Description of problem:
All the translatable strings are written out as N_("..."), not _("...").  This
is causing translatable strings redhat-config-printer to get missed completely.

Version-Release number of selected component (if applicable):
glade2-1.1.3-1

How reproducible:
100%

Steps to Reproduce:
1. Load redhat-config-printer.glade
2. Set options to save translatable strings.
3. Save.
4. Examine .str file.

Comment 1 Havoc Pennington 2003-01-06 20:17:56 UTC
I believe this is correct, N_() still gets the strings in the po files. 
_() actually calls gettext, but that doesn't matter here.

gettext is called by libglade when you pass a translation domain to 
glade_xml_new().

cc'ing pygtk hax0rs who can tell you the incantation.

Someone reopen if I'm confused.

Comment 2 Tim Waugh 2003-01-06 20:59:32 UTC
xgettext ignores the entire file.  That can't be right.  Hand-editing it to
change the relevant strings from N_ to _ fixes it.

Comment 3 Havoc Pennington 2003-01-14 20:25:03 UTC
I can't get any of the pygtk-using people to comment despite several requests so
I'm just going to reassign to jrb ;-)

Comment 4 Jonathan Blandford 2003-01-14 20:51:49 UTC
N_() is right in this case.  I'm pretty sure xgettext will just read N_() by
default.  The info page implies as much, anywaay.


Comment 5 Tim Waugh 2003-01-14 22:16:48 UTC
Well try it--it doesn't.

Comment 6 Owen Taylor 2003-10-07 20:13:09 UTC
This is not a glade bug... putting in <foo>-strings.c:

gchar *s = _("MemProf");

would not be legal C. You need to pass the --keyword=N_ option to 
xgettext if you are invoking xgettext "manually". Neither --keyword=_
or --keyword=N_ are defaults for xgettext; most invocations supply
both of them.




Comment 7 Miloslav Trmac 2003-10-07 23:19:39 UTC
This bug does not affect redhat-config-printer anymore, because it is using
intltool and there is no .glade.str file.

The original bug was caused by including --keyword=_ (and not --keyword=N_)
in xgettext invocation in redhat-config-printer's po/Makefile.
So, CURRENTRELEASE or NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.