Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81202 - unable to go online with licq (installed Perl from rawhide)
Summary: unable to go online with licq (installed Perl from rawhide)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: licq
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-06 18:25 UTC by Elton Woo
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-17 01:10:01 UTC


Attachments (Terms of Use)

Description Elton Woo 2003-01-06 18:25:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I've installed the following from rawhide:
perl-5.8.0-78.i386.rpm
perl-CGI-2.81-78.i386.rpm
perl-CPAN-1.61-78.i386.rpm
perl-DB_File-1.804-78.i386.rpm
perl-suidperl-5.8.0-78.i386.rpm

Though I am able to launch licq from the menu, attempting to go online
causes the application to abend.

If invoked from a console prompt, I get the following error:

ace]$ licq
11:02:48: [WRN] Licq: Ignoring stale lockfile (pid 5301)
 
Gtk-CRITICAL **: file gtkwidget.c: line 2449 (gtk_widget_size_allocate):
assertion `widget != NULL' failed.
 
Gtk-CRITICAL **: file gtkwidget.c: line 2449 (gtk_widget_size_allocate):
assertion `widget != NULL' failed.
 
Gtk-CRITICAL **: file gtkwidget.c: line 2449 (gtk_widget_size_allocate):
assertion `widget != NULL' failed.
/usr/lib/licq/licq-bin: relocation error: /usr/lib/licq/licq-bin: symbol
__h_errno_location, version GLIBC_2.0 not defined in file libpthread.so.0 with
link time reference


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install perl tarballs from rawhide
2.launch licq from Gnome menu OR
3.launch licq from a console command
    

Actual Results:  2)  licq wharf icon appears, but main licq window does not
reflect the correct "skin", and if user selects to go online, the main window
will crash, leaving only the licq wharf.

3) from a command prompt, licq will breifly flash the main window with the correct
'skin' but immediately dissappear, with the above error message as output.

Expected Results:  licq should launch with the correct user interface and
connect online.

Additional info:

Comment 1 Bill Nottingham 2003-01-06 22:51:39 UTC
Can you try the glibc from rawhide?

Comment 2 Elton Woo 2003-01-07 18:42:11 UTC
looks like I messed up here: I had installed *both* glib2-2.1.5-1.i386.rpm  _and_
glibc-2.3.1-26.i686.rpm. Consequently, I'm stuck beween a rock and a hard place.
I can't even remove them *or* update to glibc-2.3.1-30.i686.rpm from rawhide:

 /var/log/rpmpkgs also shows:

/usr/lib/rpm/rpmq: relocation error: /usr/lib/librpmdb-4.2.so: symbol
pthread_cond_init, version GLIBC_2.3.2 not defined in file libc.so.6 with link
time reference 

and either rpm -q {packagename} or rpm -Uvh {tarball} returns this message
root]# rpm -q glibc
/usr/lib/rpm/rpmq: relocation error: /usr/lib/librpmdb-4.2.so: symbol
pthread_cond_init, version GLIBC_2.3.2 not defined in file libc.so.6 with link
time reference

I can't even run the package manager, OR updated to
rpm-4.2-0.50.i386.rpm and rpm-build-4.2-0.50.i386.rpm from rawhide.

currently, this is what I have on the system:
         ......
glib-1.2.10-9.i386.rpm
glib2-2.1.5-1.i386.rpm
glibc-2.3.1-26.i686.rpm
glibc-common-2.3.1-26.i386.rpm
glibc-devel-2.3.1-21.i386.rpm
glibc-kernheaders-2.4-8.3.i386.rpm
glibc-profile-2.3.1-26.i386.rpm
glibc-utils-2.3.1-26.i386.rpm
     ......
rpm2html-1.8.1-4.i386.rpm
rpm-4.2-0.25.1.i386.rpm
rpm-build-4.2-0.25.1.i386.rpm
rpmdb-redhat-8.0.92-0.20021220.i386.rpm
rpm-devel-4.2-0.25.1.i386.rpm
rpm-python-4.2-0.25.1.i386.rpm
         ..... etc.

Comment 3 Thomas Woerner 2003-01-08 10:28:15 UTC
First of all, glib2 is not glibc.

I'd suggest to boot from rescue-cd and to update the glibc and all depending
packages manually.


Comment 4 Elton Woo 2003-01-11 20:39:46 UTC
I've updated with the latest packages from rawhide (Jan.10), and I can launch
licq as before
 (correct skin, etc.) However, I am UNABLE to change my online status. The
dialog window 
hangs, and though I can close the main licq panel, I'm forced to *kill* the
dialog, and licq-wharf.

currently on the system:
             ....
glibc-2.3.1-30.i686.rpm
glibc-common-2.3.1-30.i386.rpm
glibc-devel-2.3.1-30.i386.rpm
glibc-kernheaders-2.4-8.3.i386.rpm
glibc-profile-2.3.1-30.i386.rpm
glibc-utils-2.3.1-30.i386.rpm
           .......
licq-1.2.0a-6.i386.rpm
licq-gnome-1.2.0a-6.i386.rpm
licq-kde-1.2.0a-6.i386.rpm
licq-qt-1.2.0a-6.i386.rpm
          .......
rpm-4.2-0.54.i386.rpm
rpm-build-4.2-0.54.i386.rpm
rpm-devel-4.2-0.25.1.i386.rpm
rpm-python-4.2-0.54.i386.rpm
rpm2html-1.8.1-4.i386.rpm
rpmdb-redhat-8.0.92-0.20021220.i386.rpm


Comment 5 Elton Woo 2003-01-16 04:36:07 UTC
I'm updating glibc libraries (among other packages) almost nightly (latest, as 
of this writing dated Jan 13 from rawhide). I am *still* experiencing this lockup
with the dialog window whenever I try to _change my online status_.

Comment 6 Thomas Woerner 2003-01-16 10:00:03 UTC
Please try the new version licq-1.2.3-2 from rawhide.

Comment 7 Elton Woo 2003-01-17 01:05:06 UTC
I've downloaded from redhat, and now there are no more lockups. I can now
change my online status as I wish.


Note You need to log in before you can comment on or make changes to this bug.