Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81198 - Kbabel fails on paste
Summary: Kbabel fails on paste
Keywords:
Status: CLOSED DUPLICATE of bug 81200
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdesdk
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 18:13 UTC by Nikos Charonitakis
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC


Attachments (Terms of Use)

Description Nikos Charonitakis 2003-01-06 18:13:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; el-gr; rv:1.0.1) Gecko/20021003

Description of problem:
I tried to paste some translated strings from an xml file
opened with gedit but it pastes only codes not actual characters.
Then i change the file from xxx.xml to xxx.txt and open it
with mozilla browser.
Now it pastes the strings but after one or two times using
the paste function (from mozilla to Kbabel) Kbabel crashes...

here is the backtrace

no debugging symbols found)...[New Thread 8192 (LWP 2001)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40f29c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406bf1b5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x420749f9 in free () from /lib/i686/libc.so.6
#6  0x40cd7853 in operator delete(void*) (ptr=0xfffffe00)
    at ../../../../libstdc++-v3/libsupc++/del_op.cc:39
#7  0x40cd787f in operator delete[](void*) (ptr=0xfffffe00)
    at ../../../../libstdc++-v3/libsupc++/del_opv.cc:36
#8  0x40c4efe8 in QStringData::deleteSelf() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#9  0x4099c3b5 in QFont::~QFont() () from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#10 0x40a331b2 in QTextFormat::width(QChar const&) const ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x40a35126 in QTextString::width(int) const ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x40a3e916 in QTextFormatterBreakWords::format(QTextDocument*,
QTextParagraph*, int, QMap<int, QTextLineStart*> const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x40a36ea1 in QTextParagraph::format(int, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#14 0x40b16f79 in QTextEdit::formatMore() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x40b17772 in QTextEdit::insert(QString const&, bool, bool, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x40086a37 in MyMultiLineEdit::insert(QString const&, bool, bool, bool) ()
   from /usr/lib/libkbabel.so.1
#17 0x40b1ceea in QTextEdit::pasteSubType(QCString const&) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#18 0x40b184eb in QTextEdit::paste() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x40087532 in MyMultiLineEdit::paste() () from /usr/lib/libkbabel.so.1
#20 0x40b11cd3 in QTextEdit::keyPressEvent(QKeyEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#21 0x4008b48a in MsgMultiLineEdit::keyPressEvent(QKeyEvent*) ()
   from /usr/lib/libkbabel.so.1
#22 0x40a113cc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#23 0x40b117dd in QTextEdit::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#24 0x40988c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#25 0x40988540 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#26 0x406539a6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#27 0x4092e58d in QETWidget::translateKeyEvent(_XEvent const*, bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#28 0x409299e5 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#29 0x4092952f in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#30 0x4098a280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#31 0x4092902d in QApplication::exec() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#32 0x0804ca9a in main ()
#33 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.described above
2.
3.
    

Actual Results:  crash

Expected Results:  work paste fuction

Additional info:

Comment 1 Ngo Than 2003-02-01 10:15:34 UTC

*** This bug has been marked as a duplicate of 81200 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.