Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81196 - RPM will not build in a sub directory
Summary: RPM will not build in a sub directory
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 18:10 UTC by Mark Hatle
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-12 17:16:31 UTC


Attachments (Terms of Use)
Part 1 of our patch to fix this. (deleted)
2003-01-06 18:12 UTC, Mark Hatle
no flags Details | Diff
Part 2 of our patch to fix this - Hack to fix libelf from not being found properly. (deleted)
2003-01-06 18:14 UTC, Mark Hatle
no flags Details | Diff
Part 3 of our patch to fix this - Include files (deleted)
2003-01-06 18:14 UTC, Mark Hatle
no flags Details | Diff
Part 4 of our patch to fix this - db3 configure (deleted)
2003-01-06 18:16 UTC, Mark Hatle
no flags Details | Diff

Description Mark Hatle 2003-01-06 18:10:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.1) Gecko/20021030

Description of problem:
when I build software with configure I normally do:

mkdir objdir
cd objdir
../configure [options]
make

rpm does not support this correct.  (Various source files don't show up properly.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(inside of the rpm 4.1 source code directory)

1. mkdir objdir
2. cd objdir
3. ../configure [options]
4. make


Actual Results:  Software fails to build.

Expected Results:  Software should build without errors.

Additional info:

Comment 1 Mark Hatle 2003-01-06 18:12:36 UTC
Created attachment 89165 [details]
Part 1 of our patch to fix this.

These patches are designed for our system and may contain a few "short cuts"
<cough>hacks</cough>, but are generally correct.

Comment 2 Mark Hatle 2003-01-06 18:14:01 UTC
Created attachment 89166 [details]
Part 2 of our patch to fix this - Hack to fix libelf from not being found properly.

This is needed to make the building in an alternative directory work, but it is
a hack.  I was not sure of the correct fix.

Comment 3 Mark Hatle 2003-01-06 18:14:53 UTC
Created attachment 89167 [details]
Part 3 of our patch to fix this - Include files

Fix the include component when building in an alternative location.

Comment 4 Mark Hatle 2003-01-06 18:16:10 UTC
Created attachment 89168 [details]
Part 4 of our patch to fix this - db3 configure

The integrated DB3's configure shell script was unable to work in an
alternative build environment.	This should fix that.

Comment 5 Paul Nasrat 2005-06-07 21:35:52 UTC
Mark do you still require this functionality in upstream rpm?  Can you confirm
still an issue with rpm 4.4.x/HEAD?

Comment 6 Mark Hatle 2005-06-07 22:35:14 UTC
This was still broken as of RPM 4.3.  I have not tried to do this in rpm 4.4 yet.

Is this absolutly required, no.  But it's nice to be able to build in an objdir.

Feel free to change this to an enhancement request.

Comment 7 Paul Nasrat 2005-09-29 18:54:31 UTC
Changing to enhancement - rediff against HEAD/rpm 4.4.x will certainly expediate.

Comment 8 Jeff Johnson 2006-02-12 17:16:31 UTC
Almost all of the changes have been applied. The perl subdir still has problems, but
that's because of the way in which "perl Makefile.PL" and MakeMaker are wired up.

Deferred until somewhen.


Note You need to log in before you can comment on or make changes to this bug.