Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81194 - support of older kernels is broken in kernel-pcmcia-cs-3.1.31-11
Summary: support of older kernels is broken in kernel-pcmcia-cs-3.1.31-11
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 18:07 UTC by Leonid Kanter
Modified: 2015-01-04 22:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-25 07:24:56 UTC


Attachments (Terms of Use)

Description Leonid Kanter 2003-01-06 18:07:37 UTC
Description of problem:

Because usb hotplug is broken in phoebe, I tried to use older kernel with it
(2.4.18-18.8) and found that there is a bug in pcmcia start script

Version-Release number of selected component (if applicable):

kernel-pcmcia-cs-3.1.31-11

How reproducible:

always

Steps to Reproduce:
1.install phoebe on laptop, install kernel-2.4.18-18.8
2.configure pcmcia, run service pcmcia start
    
Actual results:

Starting PCMCIA services: modulesmodprobe: Can't locate module
/lib/modules/2.4.18-18.8/pcmcia/pcmcia_core.o
modprobe: Can't locate module /lib/modules/2.4.18-18.8/pcmcia/yenta_socket.o
modprobe: Can't locate module /lib/modules/2.4.18-18.8/pcmcia/ds.o

Expected results:

must start silently

Additional info:

modprobe cannot be called with full module path, insmod must be used here. This
patch fixes problem and do not brake new kernel (2.4.20-2.2) support.

--- /etc/rc.d/init.d/pcmcia.orig        Sun Jan  5 20:26:24 2003
+++ /etc/rc.d/init.d/pcmcia     Sun Jan  5 20:26:53 2003
@@ -104,9 +104,9 @@
            KD=/lib/modules/`uname -r`/kernel/drivers/pcmcia
            if [ -d $PC ] ; then
                echo -n " modules"
-               /sbin/modprobe $PC/pcmcia_core.o $CORE_OPTS
-               /sbin/modprobe $PC/$PCIC.o $PCIC_OPTS
-               /sbin/modprobe $PC/ds.o
+               /sbin/insmod $PC/pcmcia_core.o $CORE_OPTS
+               /sbin/insmod $PC/$PCIC.o $PCIC_OPTS
+               /sbin/insmod $PC/ds.o
            elif [ -d $KD ] ; then
                /sbin/modprobe pcmcia_core
                /sbin/modprobe $PCIC

Comment 1 Arjan van de Ven 2003-01-06 23:29:48 UTC
thanks for the report!
I've changed it to keep using modprobe but without the directory
should work just as well (and the modutils maintainer asked me to make it never
use modprobe ever)

Comment 2 Leonid Kanter 2003-01-07 16:42:12 UTC
Did you mean "never use _insmod_ ever"?


Note You need to log in before you can comment on or make changes to this bug.