Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81190 - rpm BuildRequires: elfutils-devel
Summary: rpm BuildRequires: elfutils-devel
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 17:04 UTC by Jon Willeke
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC


Attachments (Terms of Use)

Description Jon Willeke 2003-01-06 17:04:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I tried to build RPM to test the fix for bug 75057.  The build failed in
debugedit.c, because gelf.h and dwarf.h were not present.  These are provided by
elfutils-devel.

The spec file (and possibly the configure script) should catch this dependency.
 Note that RPM 4.2-0.25.1 in RH 8.0 does specify BuildRequires: elfutils-devel.

Version-Release number of selected component (if applicable):
4.2-0.50

How reproducible:
Always

Steps to Reproduce:
1. confirm that elfutils-devel is not installed
2. confirm that gelf.h and dwarf.h are not present
3. rpmbuild --rebuild rpm-4.2-0.50.src.rpm
    

Actual Results:  Build aborts compiling debugedit.c.

Expected Results:  Build should abort immediately if elfutils-devel is not
installed.

Additional info:

Comment 1 Jeff Johnson 2003-02-18 16:44:15 UTC

*** This bug has been marked as a duplicate of 84526 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.