Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81181 - ethereal exits when stopping capture file parsing.
Summary: ethereal exits when stopping capture file parsing.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: ethereal
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 15:22 UTC by Pavel
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-23 14:03:47 UTC


Attachments (Terms of Use)

Description Pavel 2003-01-06 15:22:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030105

Description of problem:
Ethereal displays progress dialog while parsing long capture file. If I press
"Stop" button in the dialog, ethereal just exits. When I run ethereal from gdb,
it says "program exited normally".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run ethereal and press "Stop" button during capture parsing
2.
3.
    

Actual Results:  Ethereal exits.

Expected Results:  Stop parsing and stay working.

Additional info:

Comment 1 Guy Harris 2003-01-10 00:18:26 UTC
That was the intended behavior when the dialog box and Stop button was first put 
in - if you want it to, instead, close the file it's reading and clear the list 
of packets, but keep running, send mail to ethereal-users@ethereal.com asking 
for that (as this isn't something Red Hat added, it's the way the regular 
Ethereal release works).


Note You need to log in before you can comment on or make changes to this bug.