Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81178 - anaconda's grub config fails to recognise all Linux partitions
Summary: anaconda's grub config fails to recognise all Linux partitions
Keywords:
Status: CLOSED DUPLICATE of bug 78704
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 13:58 UTC by Richard Lloyd
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC


Attachments (Terms of Use)

Description Richard Lloyd 2003-01-06 13:58:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
When anaconda reaches its grub configuration section,
it should list all OS partitions available.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure a machine has a pre-existing Linux partition that
   isn't going to be wiped/upgraded by phoebe.
2. Boot phoebe CD-ROM 1 and run anaconda.
3. Put phoebe onto a different partition than the one listed
   in step 1.
4. Note what default menu entries for grub are listed in anaconda.
    

Actual Results:  Only "Red Hat Linux" (the one it's currently installing)
and possibly "DOS" (which was a Win 98 SE partition in my case) are
listed as default grub menu entries.

Expected Results:  Other Linux partitions (I also had RH 8.0 and Mandrake Linux 9.0
in my partitions) should be listed in the default grub entries, not just
phoebe and the Windows partition.

Additional info:

Considering that phoebe *does* detect all the Linux partitions early
on (when it's offering to "upgrade" - this is a new phoebe feature
in fact), it's disappointing that it forgets about most of them when
it comes to setting up the grub menu entries. Yes, you can add new
entries in via anaconda (or post-install by editing /etc/grub.conf),
but anaconda knows about those partitions and hence I shouldn't have
to add them by hand.

On a side-note, I don't like the "DOS" label for the Windows
partition - it would be nice to have "Windows 98 SE", "Windows
XP Home Edition" etc. etc. listed instead if that's possible.

Comment 1 Mike McLean 2003-01-06 18:19:19 UTC

*** This bug has been marked as a duplicate of 78704 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.