Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81168 - /proc/lvm and /etc/lvmtab created when no LVM selected
Summary: /proc/lvm and /etc/lvmtab created when no LVM selected
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
: 80851 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-06 13:07 UTC by Richard Lloyd
Modified: 2007-04-18 16:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 14:15:56 UTC


Attachments (Terms of Use)

Description Richard Lloyd 2003-01-06 13:07:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
After a non-LVM installation of phoebe,
/proc/lvm and /etc/lvmtab are created,
which they probably shouldn't be.

This also causes the machine boot sequence to
report a message from vgchange that
there are no volume groups.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install phoebe, but make sure you don't use LVM.
2. Look at the boot sequence to look for vgchange messages.
3. Look for the existence of /proc/lvm and /etc/lvmtab.
    

Actual Results:  /proc/lvm and /etc/lvmtab (the latter is a 1-byte "empty" file)
are created, plus a vgchange warning message is also displayed during
the phoebe boot sequence because of this.

Expected Results:  In a non-LVM Red Hat 8.0 system, /proc/lvm and /etc/lvmtab don't
exist and there is no vgchange warning message.

Additional info:

My suspicion is that anaconda is running "vgscan" at some point during
the installation of phoebe when it probably shouldn't if a non-LVM
system is being installed. It is "vgscan" that creates /proc/lvm
and /etc/lvmtab in case you're wondering.

Also note that the tests in /etc/rc.d/rc.sysinit that decide whether
to run "vgscan" and possibly "vgchange" now become true in phoebe's
case, even on a non-LVM system:

if [ -e /proc/lvm -a -x /sbin/vgchange -a -f /etc/lvmtab ]; then
        action $"Setting up Logical Volume Management:" /sbin/vgscan &&
/sbin/vgchange -a y
fi

This is where the vgchange warning about no volume groups comes from.

Comment 1 Jeremy Katz 2003-01-08 22:30:05 UTC
Fixed in CVS

Comment 2 Stephen Tweedie 2003-01-13 14:43:57 UTC
*** Bug 80851 has been marked as a duplicate of this bug. ***

Comment 3 Jay Turner 2003-01-21 14:15:56 UTC
Issue is resolved with anaconda-8.0.94-0.20030120155450.


Note You need to log in before you can comment on or make changes to this bug.