Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81163 - sv-latin1.map.gz layout should be named se-latin1.map.gz
Summary: sv-latin1.map.gz layout should be named se-latin1.map.gz
Keywords:
Status: CLOSED DUPLICATE of bug 80391
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 11:37 UTC by Christian Rose
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:57 UTC


Attachments (Terms of Use)
Contents of /etc/sysconfig/keyboard (deleted)
2003-01-06 14:50 UTC, Christian Rose
no flags Details
Output from /etc/init.d/keytable restart (deleted)
2003-01-06 14:56 UTC, Christian Rose
no flags Details
Output from sh -x /etc/init.d/keytable restart (deleted)
2003-01-06 14:59 UTC, Christian Rose
no flags Details
Output from sh -x /etc/init.d/keytable start (deleted)
2003-01-06 17:13 UTC, Christian Rose
no flags Details

Description Christian Rose 2003-01-06 11:37:30 UTC
Tested with Phoebe, and a fresh install.

I selected the "Swedish" keyboard during the install, and I also got one
in X. However, when I use the console, Swedish characters don't work.
Instead, it uses an American keyboard layout, contrary to what was selected in
anaconda during the installation.

Comment 1 Milan Kerslager 2003-01-06 14:30:37 UTC
See what you have in /etc/sysconfig/keyboard.
Try to run /etc/init.d/keytable restart.

When keytable script will not work, try to run in by:

sh -x /etc/init.d/keytable restart

and grab what you see.

keytable script should be run on startup (see ntsysv or chkconfig --list | grep
keytable).

Comment 2 Christian Rose 2003-01-06 14:50:58 UTC
Created attachment 89157 [details]
Contents of /etc/sysconfig/keyboard

Comment 3 Christian Rose 2003-01-06 14:56:35 UTC
Created attachment 89158 [details]
Output from /etc/init.d/keytable restart

"MISSLYCKADES" is the Swedish translation of "FAILED"
"Läser in" = "Loading"
"tangentbordslayout" = "keyboard layout"
"systemtypsnitt" = "system font"

Comment 4 Christian Rose 2003-01-06 14:59:23 UTC
Created attachment 89159 [details]
Output from sh -x /etc/init.d/keytable restart

Comment 5 Christian Rose 2003-01-06 15:02:38 UTC
Keytable is on on all runlevels except 0 and 6 on the system.


Comment 6 Milan Kerslager 2003-01-06 17:07:23 UTC
Sorry, the output is not complete because script "restart" call self with
"start". So try again please:

sh -x /etc/init.d/keytable start

Comment 7 Christian Rose 2003-01-06 17:13:49 UTC
Created attachment 89162 [details]
Output from sh -x /etc/init.d/keytable start

Comment 8 Milan Kerslager 2003-01-06 17:38:06 UTC
I don't have /lib/kbd/keymaps/i386/qwerty/se-latin1.map.gz. Try:

ls /lib/kbd/keymaps/i386/qwert?/se*

and pick up one of available keymaps. Modify /etc/sysconfig/keyboard and try to
use keytable script to load keymap.

The bug could be:

a) Anaconda should use another keymap because the se-latin1 keymap not exist    
   anymore in kbd tarball
b) kbd RPM package do not contain your keymap (bad SPEC file or so)

Look in kbd SRC package and you will se if your keymap is inside tarball (use mc
or try to build RPM package and look into BUILD directory.

Comment 9 Christian Rose 2003-01-06 17:51:56 UTC
The "se-latin1" value is correct; that's the same value as has always been for
the standard Swedish keyboard.

The problem seems indeed to be in kbd: A
/lib/kbd/keymaps/i386/qwerty/se-latin1.map.gz
does not exist anymore in Phoebe (it existed in previous releases), but instead
there is now a
/lib/kbd/keymaps/i386/qwerty/sv-latin1.map.gz
As keyboard layouts should be defined based on country/region (please correct me
if I'm wrong) and not on language codes (sv is the language code for Sweden, se
is the country code), I think there is a clear bug here. Especially since the
other "se" layouts weren't renamed.

Comment 10 Christian Rose 2003-01-06 18:04:31 UTC
Seems like this is a dup of the (non-beta-only) bug 80391.

Comment 11 Bill Nottingham 2003-01-06 22:41:57 UTC

*** This bug has been marked as a duplicate of 80391 ***

Comment 12 Red Hat Bugzilla 2006-02-21 18:50:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.