Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8115 - Serial Ports not left as found.
Summary: Serial Ports not left as found.
Keywords:
Status: CLOSED DUPLICATE of bug 7852
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-02 19:22 UTC by Neil Darlow
Modified: 2014-03-17 02:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-18 17:03:12 UTC


Attachments (Terms of Use)

Description Neil Darlow 2000-01-02 19:22:37 UTC
The Serial Port probe prevents attached modems going off-hook at first
attempt.

This problem was noticed with diald where the first connect attempt after
boot would consistently fail. Subsequent connect attempts were ok.

The solution I adopted was to add the -s option to the kudzu commandline
in /etc/rc.d/init.d/kudzu.

Perhaps more work needs to be done to ensure that the UART is left in the
same state after the probe as it was before.

Comment 1 Bill Nottingham 2000-01-03 16:22:59 UTC
Are you using the updated pppd & initscripts? There
was a double-dial problem with those...

Comment 2 Neil Darlow 2000-01-04 10:03:59 UTC
The packages in use are:

  initscripts-4.70-1
  ppp-2.3.10-3

I check for updates weekly and install as appropriate.

Comment 3 Bill Nottingham 2000-01-04 19:42:59 UTC
What sorts of modems?

Comment 4 Bill Nottingham 2000-01-04 19:43:59 UTC
(and what are they detected as, if anything, in /etc/sysconfig/hwconf?)

Comment 5 Neil Darlow 2000-01-05 07:38:59 UTC
Modular Technology SuperHighway 56 External modem.
Rockwell-based V.90/K56Flex auto-sensing:

ATI0: 56000
ATI1: 060
ATI2:
ATI3: V1.200-K56_DLS
ATI4: K56flex data+fax+voice modem version 2.00 (R1.200)+c  10/Dec/97
ATI5: 016
ATI6: RCV56DPF L8570A Rev 45.0/45.0
ATI7: 000

/etc/sysconfig/hwconf:
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|430TX - 82439TX MTXC"
vendorId: 8086
deviceId: 7100
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 ISA"
vendorId: 8086
deviceId: 7110
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 IDE"
vendorId: 8086
deviceId: 7111
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 USB"
vendorId: 8086
deviceId: 7112
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corporation|82371AB PIIX4 ACPI"
vendorId: 8086
deviceId: 7113
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Brooktree Corporation|Bt848 TV with DMA push"
vendorId: 109e
deviceId: 0350
-
class: NETWORK
bus: PCI
detached: 0
driver: ne2k-pci
desc: "Realtek|8029"
vendorId: 10ec
deviceId: 8029
-
class: VIDEO
bus: PCI
detached: 0
driver: Card:S3 ViRGE (generic)
desc: "S3 Inc.|ViRGE/DX or /GX"
vendorId: 5333
deviceId: 8a01
-
class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: ignore
desc: "Generic PS/2 Mouse"
-
class: CDROM
bus: IDE
detached: 0
device: hdb
driver: ignore
desc: "CRD-8240B"
-
class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "   lg CD-ROM CRD-8240B"
host: 0
id: 0
channel: 0
lun: 0
-
class: HD
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "SAMSUNG VG34323A (4.32GB)"
physical: 14896/9/63
logical: 14896/9/63
-
class: HD
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "SAMSUNG VG34323A (4.32GB)"
physical: 14896/9/63
logical: 14896/9/63

Comment 6 Bill Nottingham 2000-01-18 17:03:59 UTC
*** This bug has been marked as a duplicate of 7852 ***


Note You need to log in before you can comment on or make changes to this bug.