Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81144 - logwatch keeps complaining of "Malformed UTF-8 character"
Summary: logwatch keeps complaining of "Malformed UTF-8 character"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
: 88293 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-06 04:38 UTC by Aleksey Nogin
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version: 4.3.2-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-10 15:20:54 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 2003-01-06 04:38:46 UTC
Every few days I would receive a 200-500Kb long cron message with hundreds lines
of the form:

Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 17.

This used to be happening a lot with 8.0 and seems to be still happening in Phoebe.

P.S. I am running my system with LANG="ru_RU.UTF-8"

Comment 1 Elliot Lee 2003-02-19 23:22:19 UTC
Try logwatch 4.3.1 please

Comment 2 Aleksey Nogin 2003-03-04 11:31:53 UTC
Just got it in beta5 with logwatch-4.3.1-2: 

/etc/cron.daily/00-logwatch:

Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 355.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 355.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 356.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 356.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 357.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 357.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
Malformed UTF-8 character (unexpected non-continuation byte 0x5c, immediately
after start byte 0xd0) in pattern match (m//) at
/etc/log.d/scripts/shared/removeservice line 29, <STDIN> line 110.
...

And it goes on for a total of 648K of these messages!

Comment 3 Elliot Lee 2003-04-11 16:58:02 UTC
*** Bug 88293 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.