Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81132 - ide-scsi code in kernel-2.4.20-2.2 doesn't seem to work
Summary: ide-scsi code in kernel-2.4.20-2.2 doesn't seem to work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-06 01:20 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 09:41:57 UTC


Attachments (Terms of Use)

Description Nathan G. Grennan 2003-01-06 01:20:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Description of problem:
When I put hdc=ide-scsi on the kernel line for grub I end up with


Jan  5 13:42:04 cygnusx-1 kernel: ide-scsi: hdc: unsupported command in request
queue (0)
Jan  5 13:42:04 cygnusx-1 kernel: end_request: I/O error, dev 16:1e (hdc), sector 4
Jan  5 13:42:04 cygnusx-1 kernel: ide-scsi: hdc: unsupported command in request
queue (0)
Jan  5 13:42:04 cygnusx-1 kernel: end_request: I/O error, dev 16:1e (hdc), sector 6
Jan  5 13:42:04 cygnusx-1 kernel: ide-scsi: hdc: unsupported command in request
queue (0)
Jan  5 13:42:04 cygnusx-1 kernel: end_request: I/O error, dev 16:1f (hdc), sector 0
Jan  5 13:42:04 cygnusx-1 kernel: ide-scsi: hdc: unsupported command in request
queue (0)
Jan  5 13:42:04 cygnusx-1 kernel: end_request: I/O error, dev 16:1f (hdc), sector 2
Jan  5 13:42:04 cygnusx-1 kernel: ide-scsi: hdc: unsupported command in request
queue (0)
Jan  5 13:42:04 cygnusx-1 kernel: end_request: I/O error, dev 16:1f (hdc), sector 4


I get the same thing with hda when I put in hda=ide-scsi.

There are on my onboard VIA controller:

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev
06) (prog-if 8a [Master SecP PriP])
Subsystem: VIA Technologies, Inc. VT8235 Bus Master ATA133/100/66/33 IDE

hda is my Pacific Digital 48x12x48 CDRW drive
hdc is my Creative 6x DVD-ROM drive

I setup the dvd drive with scsi emulation so that I can do cd to cd copying and
it is consistant tiwht the cdrw drive. I have always done this in the past and
did it with the same hardware and 2.4.18-19.8.0 under RedHat 8.0.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add hdc=ide-scsi to the kernel line in grub.conf
2. reboot

    

Actual Results:  errors in dmesg

Expected Results:  Something like this in dmesg

scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: HL-DT-ST  Model: CD-RW GCE-8240B   Rev: 1.08
  Type:   CD-ROM                             ANSI SCSI revision: 02


Additional info:

The drives work fine without scsi-emulation, but of course I need scsi emulation
for cd burning.

Comment 1 Nathan G. Grennan 2003-01-06 03:09:36 UTC
Upgraded to 2.4.20-2.6 and the scsi-emulation problem is fixed.

Comment 2 Nathan G. Grennan 2003-01-07 14:02:32 UTC
Since 2.4.20-2.6 has been abandoned I am reopening to bug to make sure it isn't
forgotten.

Comment 3 Nathan G. Grennan 2003-01-14 09:41:57 UTC
Works in 2.4.20-2.9 and beyond


Note You need to log in before you can comment on or make changes to this bug.