Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81117 - gnome-terminal crashes with multiple segmentation faults
Summary: gnome-terminal crashes with multiple segmentation faults
Keywords:
Status: CLOSED DUPLICATE of bug 80414
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 9
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On: 80414
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-05 01:49 UTC by Tommy McNeely
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:56 UTC


Attachments (Terms of Use)

Description Tommy McNeely 2003-01-05 01:49:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
This is the error I get the first time... (after restarting)

(the window sorta appears then dis-appears)

$ gnome-terminal 
Xlib:  extension "RENDER" missing on display ":0.0".

Gdk-ERROR **: The program 'gnome-terminal' received an X Window System
error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 1088 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
aborting...

(process:30745): Gdk-ERROR (recursed) **: The program 'gnome-terminal'
received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadGC (invalid GC parameter)'.
  (Details: serial 1091 error_code 13 request_code 60 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)
aborting...
Multiple segmentation faults occurred; can't display error dialog


If I try to run it again, the window appears with nothing in it. The
machine starts to get slower and slower as gnome-terminal takes up all
my ram and swap, then the machine becomes unusable (except to push the
reset button cause I am impatient).

I can do "ALT+F2" and use xterm for now :)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. startx
2. right-click then select New Terminal (or start gnome-terminal from an XTERM
3. BOOM ?
    

Actual Results:  it crashes or brings the system down

Expected Results:  a terminal window :)

Additional info:


[tommy@binkey tommy]$ xdpyinfo 
name of display:    :0.0
version number:    11.0
vendor string:    The XFree86 Project, Inc
vendor release number:    40299002
XFree86 version: 4.2.99.2
maximum request size:  4194300 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x160000e, revert to PointerRoot
number of extensions:    25
    BIG-REQUESTS
    DOUBLE-BUFFER
    DPMS
    Extended-Visual-Information
    FontCache
    LBX
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    RANDR
    SECURITY
    SHAPE
    SYNC
    TOG-CUP
    X-Resource
    XC-APPGROUP
    XC-MISC
    XFree86-Bigfont
    XFree86-DGA
    XFree86-Misc
    XFree86-VidModeExtension
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    1152x864 pixels (390x293 millimeters)
  resolution:    75x75 dots per inch
  depths (1):    24
  root window id:    0x25
  depth of root window:    24 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x21
  default number of colormap cells:    256
  preallocated pixels:    black 0, white 16777215
  options:    backing-store NO, save-unders NO
  largest cursor:    64x64
  current input event mask:    0xfa203f
    KeyPressMask             KeyReleaseMask           ButtonPressMask          
    ButtonReleaseMask        EnterWindowMask          LeaveWindowMask          
    ButtonMotionMask         StructureNotifyMask      SubstructureNotifyMask   
    SubstructureRedirectMask FocusChangeMask          PropertyChangeMask       
    ColormapChangeMask       
  number of visuals:    1
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    TrueColor
    depth:    24 planes
    available colormap entries:    256 per subfield
    red, green, blue masks:    0xff0000, 0xff00, 0xff
    significant bits in color specification:    8 bits
[tommy@binkey tommy]$ uname -a
Linux binkey.local.redneck.nu 2.4.20-2.2 #1 Fri Dec 20 12:33:26 EST 2002 i686
athlon i386 GNU/Linux

----

The machine is a VMWARE machine (virtual) with a standard "linux" config + the
iso's are available as CDROMS

[tommy@cookies RedHatBeta]$ cat linux.cfg
#!/usr/bin/vmware
config.version = 6
virtualHW.version = 2
displayName = "RedHatBeta"

# CD-ROM
ide1:0.present = "TRUE"
ide1:0.fileName = "/share/iso/RedHat/phoebe/phoebe-i386-disc1.iso"
ide1:0.deviceType = "cdrom-image"
ide1:0.startConnected = "TRUE"

# Virtual hard disk on scsi0:0
scsi0.present = TRUE
scsi0:0.present = TRUE
scsi0:0.fileName = linux.vmdk
scsi0:0.deviceType = scsi-hardDisk
scsi0:0.mode = persistent
scsi0:0.writethrough = FALSE

# No floppy installed
floppy0.present = FALSE

# Networking bridged to real ethernet
ethernet0.present = TRUE
ethernet0.connectionType = bridged

# Memory size
memsize = 256

# Nvram
nvram = linux.nvram

# Log file
log.fileName = linux.log

# Hints
guestOS = "linux"

scsi0:4.present = "TRUE"
scsi0:4.deviceType = "cdrom-image"
scsi0:4.fileName = "/share/iso/RedHat/phoebe/phoebe-i386-disc1.iso"
scsi0:5.present = "TRUE"
scsi0:5.deviceType = "cdrom-image"
scsi0:5.fileName = "/share/iso/RedHat/phoebe/phoebe-i386-disc2.iso"
scsi0:6.present = "TRUE"
scsi0:6.deviceType = "cdrom-image"
scsi0:6.fileName = "/share/iso/RedHat/phoebe/phoebe-i386-disc3.iso"
tools.remindInstall = "FALSE"
mouse.hostType = "autodetect"
mouse.fileName = ""

gui.powerOnAtStartup = "TRUE"
apmSuspend = "FALSE"
suspendToDisk = "TRUE"
gui.exitAtPowerOff = "FALSE"
hard-disk.enableIBR = "FALSE"
gui.fullScreenResize = "TRUE"
resume.repeatable = "FALSE"
disable_acceleration = "FALSE"
sound.present = "TRUE"
sound.device = "/dev/dsp"
gui.fullScreenAtPowerOn = "FALSE"
redoLogDir = ""
logging = "TRUE"
debug = "FALSE"

Comment 1 Tommy McNeely 2003-01-05 04:58:57 UTC
Okay.. After talking to HP .. this is probably a duplicate of Bug #80414 .

Tommy

Comment 2 Tommy McNeely 2003-01-05 06:26:12 UTC

*** This bug has been marked as a duplicate of 80414 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.