Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81115 - Adding Apache to workstation install doesn't prompt to reboot for HTTP to show in Services
Summary: Adding Apache to workstation install doesn't prompt to reboot for HTTP to sho...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd
Version: 8.0
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-05 00:17 UTC by Whil Hentzen
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-06 14:57:10 UTC


Attachments (Terms of Use)

Description Whil Hentzen 2003-01-05 00:17:21 UTC
Description of problem:
"HTTP Server" doesn't show up in Server Settings menu after installation of Apache

Version-Release number of selected component (if applicable):
RHL 8.0

How reproducible:
Only tried once - only installed Apache once - tried rebooting a couple times
but nothing changed.

Steps to Reproduce:
1. Install Apache from 8.0 CDs
2. Rebooted machine.
3. Server Settings menu doesn't have "HTTP Server"  listed
4. Turned HTTPD on in Server Settings | Services
5. Server Settings menu still doesn't have "HTTP Server" listed
    
Actual results:
No "HTTP Server" available

Expected results:
An "HTTP Server" menu item to be available.

Additional info:
Apache is installed - httpd is installed under /etc and I was able to find the
httpd.conf file, for example.

Comment 1 Whil Hentzen 2003-01-05 00:21:49 UTC
After another reboot, I checked the boot logs. httpd startup was successful
(except that it can't find the server's fully qualified domain name, so it's
using 127.0.0.1... duh. Once I get the config tool working, I can update the
FQDN...)


Comment 2 Miloslav Trmac 2003-01-06 15:07:07 UTC
NOTABUG, you need to install redhat-config-httpd.

Comment 3 Michael Lee Yohe 2003-01-06 17:04:20 UTC
Confirming, NOTABUG

Comment 4 Whil Hentzen 2003-01-06 22:38:37 UTC
So if you include Apache during an initial install, the config dialog is
installed, but if you install it later, during an upgrade, the config dialog
isn't installed? This is _intended_ behavior? Why?

Comment 5 Phil Knirsch 2003-02-06 14:57:10 UTC
Because httpd doesn't require this tool and it is not part of the httpd package
but a separate configuration tool.

Closing this bug now.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.