Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81104 - libtiff doesn't build
Summary: libtiff doesn't build
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libtiff
Version: 1.0
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-04 20:20 UTC by franz.sirl-kernel
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 17:06:41 UTC


Attachments (Terms of Use)

Description franz.sirl-kernel 2003-01-04 20:20:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
I wonder what tricks are used at RH to build this package, it simply doesn't
work for me.
Each rpm --rebuild gives me:

...
Creating Makefile from ./Makefile.in
Creating libtiff/Makefile from ./libtiff/Makefile.in
Creating man/Makefile from ./man/Makefile.in
Creating tools/Makefile from ./tools/Makefile.in
Creating port/install.sh from ./port/install.sh.in
Done.
+ cd libtiff
+ ln -s libtiff.so.3.5 libtiff.so
+ cd ..
+ export LDOPTS=-s
+ LDOPTS=-s
+ make 'LIBJPEG=-L/usr/lib -ljpeg' 'LIBGZ=-L/usr/lib -lz'
= libtiff
make: invalid option -- L
Usage: make [options] [target] ...
Options:
  -b, -m                      Ignored for compatibility.
  -C DIRECTORY, --directory=DIRECTORY
...

It seems the culprit is the original tiff-v3.5.7/Makefile.in, it contains:

...
all default:
        @if [ "no" = yes ]; then \
            ${ECHO} "= "port; cd port; ${MAKE} -${MAKEFLAGS}; \
        else \
            true; \
        fi
        @${ECHO} "= "libtiff; cd libtiff; ${MAKE} -${MAKEFLAGS}
        @${ECHO} "= "tools; cd tools; ${MAKE} -${MAKEFLAGS}
        @${ECHO} "= "man; cd man; ${MAKE} -${MAKEFLAGS}
...

Note the dashes (-) in front of ${MAKEFLAGS}? Together with the LIBJPEG= command
line argument they form the "invalid" -L option for make.


Version-Release number of selected component (if applicable):
3.5.7-8

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild libtiff src rpm
2.
3.
    

Additional info:

Comment 1 Jonathan Blandford 2003-01-24 21:38:33 UTC
Current Rawhide (libtiff-3.5.7-9.src.rpm) works for me.


Comment 2 franz.sirl-kernel 2003-02-01 21:48:10 UTC
Now I found out why it works for you, you are building on a SMP machine, or?
Try on a UP one or remove the %{?_smp_mflags} from the make invocation in the
specfile and watch it failing.


Comment 3 Phil Knirsch 2003-02-11 17:06:41 UTC
OK, verified and fixed in libtiff-3.5.7-11, building right now and available via
rawhide soon.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.