Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81098 - the ability to select a different keyboard model in GUI
Summary: the ability to select a different keyboard model in GUI
Keywords:
Status: CLOSED DUPLICATE of bug 80885
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-keyboard
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-04 16:00 UTC by Daniel Resare
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:55 UTC


Attachments (Terms of Use)

Description Daniel Resare 2003-01-04 16:00:25 UTC
Description of problem:

I selected the wrong (pc102) keyboard in the installer, and now I would like to
swith it to a pc105 keyboard to get the Super key working. It would be nice to
be able to do that i the redhat-config-keyboard GUI.

I think that the current model with XkbLayout and XkbModel combined in one list
is not the best idea, two lists would be much better

Comment 1 Brent Fox 2003-01-04 16:58:25 UTC
The keyboard screen in anaconda used to have a list of models and a list of
layouts.  We did some usablility studies and that screen was a disaster.  In our
group of new users, they actually started counting the keys on their keyboard to
see if they had a pc101, pc104, or pc105 keyboard.  Clearly not user friendly.

I changed rhpl yesterday so that all keyboards will default to the pc105 layout.
 If the keyboard is a pc101, I think that the 105 layout will work just fine
since the keyboard just lacks the keys to emit those extra signals.  I think
this solves the problem in a more elegant way than to go back to the old way of
users counting keys.

This change should also affect anaconda, since it uses the same code base as
redhat-config-keyboard and rhpl.

Please see bug #80885 for more information.

*** This bug has been marked as a duplicate of 80885 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.