Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 81092 - httpd won't start when adding multiple listening ports using the configurator.
Summary: httpd won't start when adding multiple listening ports using the configurator.
Keywords:
Status: CLOSED DUPLICATE of bug 75210
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-04 04:56 UTC by Lemster
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:55 UTC


Attachments (Terms of Use)

Description Lemster 2003-01-04 04:56:53 UTC
Description of problem: Apache server configurator, when adding multiple
listening ports, the output string httpd.conf file -> Listen *.80 *.xxx where
xxx another port. Apache don't like it. Need to have Listen *.80 <newline>
Listen *.xxx


Version-Release number of selected component (if applicable): 8.0 patched all to
latest releases, clean install.


How reproducible: always


Steps to Reproduce:
1.goto "server settings" + "http server" from redhat start menu
2.add a new port, in additon to the standard port 80
3.save the file
4.bounce httpd -> go to /etc/init.d/httpd restart
    
Actual results:

http crashes

<snippit start>
Starting httpd: Syntax error on line 146 of /etc/httpd/conf/httpd.conf:
Listen takes one argument, A port number or a numeric IP address and a port number
                                                           [FAILED]

<snippit end>


Expected results:

Well I suppose it should say [OK] instead of [FAILED]



Additional info:

Happy New Year!

Comment 1 Joe Orton 2003-01-13 17:44:27 UTC

*** This bug has been marked as a duplicate of 75210 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.